The larger of Apple's MacBook Air laptops featuring dual microphones and 802.11ac Wi-Fi connectivity.

210 Questions View all

Icons keep on changing to a Ruler/Caliper

Block Image

Hello all,

I am new to this forum. I have an issue where my "dock" icons keep on changing to a ruler and a caliper. More specifically this happens to my league of legends icon and my system preferences icon. Please let me know how to fix this aside from the "killall Dock" option. Due to the fact that this helps only once, it doesn't fix the issue permanently. What I did to fix this is clearing caches, clearing my hard drive a bit making a free space of 43gb even though I think that's not the solution. Cleared my desktop icons to 0 only my external drives appear there now. I appreciate all the help and support. Let's see how we can fix this, best answer wins :) :P

PS. Let me know if you can see the uploaded picture, thank you again. :)

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

No image, here's how to upload it:

Adding images to an existing question

by

Hello,

I work with several customize docks on my Macs and Images, if you can include a photo or link to your photo so we can see what you are looking to revert icons to default or a custom look.

Please advise

Thanks

www.MacOSGenius.com

by

Picture added :) I had to insert the link for that picture in order to appear. Ok, I didn't know that sorry. I happens to my league of legends client, and my system preferences sometimes. It also happened to my Spotify inside the launchpad but it turned back to normal on its own. The icon you see there it is my lol icon it is not a client issue it is a mac issue because it happens with system preferences as well. Thank you in advance for your help :)

by

Add a comment

1 Answer

Chosen Solution

You lost it when you cleared your caches.

Try resetting the system’s launch services, this can be done by running the following command in the OS X Terminal. Note that the command is buried deep in the system so it is very long; however, you should be able to copy the following multi-line version of it and paste it into the Terminal to run it:

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -seed

Was this answer helpful?

Score 4

Comments:

First of all thank you for your help. I tried the command you gave me but it didn't fix it. I keep on getting the same icon. I run the cmd on terminal, and restarted my mac and then did all I'm doing. But I'm still getting that icon. Any more ideas?

by

Add a comment

Add your answer

cleanslate will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 69