Second generation of iPhone. Model A1241 / 8 or 16 GB capacity / black or white plastic back. Repair is more straightforward than the first iPhone. requires screwdrivers, prying, and suction tools.

1492 Questions View all

iPhone 3G Freeze Right Before Custom ipsw Restore, Getting Error 9.

I Have recently come across a few 3G iPhones that are stuck in recovery. Both iPhones have been running iOS 3.1.3 and to my knowledge they have not updated their baseband to 6.15.00. In Every attempt to recover their iPhones I get error 9 or it freezes right before a custom restore (When the apple logo with the bar first appears). Just looking for anyones input thanks.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

3 Answers

Chosen Solution

http://support.apple.com/kb/TS1275

seems like it could be your USB or security software causing the issue- which if it is, would be so much better than a hardware problem! good luck

Update

Connect iPhone, iPad, iPod touch or Apple TV (2nd generation) to a different USB port on your Mac or Windows PC. USB 2.0 ports that are built in to the computer are preferred over a hub. If you tried connecting your device to USB ports on the front of the computer, try connecting them to rear USB ports. After doing this, try to restore the device in iTunes.

If the issue continues:

Remove all USB devices except the keyboard, mouse, and your iPhone, iPad, iPod or Apple TV (2nd generation).

Remove all USB hubs and connect your iOS device directly to the computer. If your display has a USB connection, disconnect all USB devices from it.

Connect your device directly to the included USB cable, bypassing the dock.

Restart the computer.

Try to restore the device again in iTunes.

If available, test with alternative, known-good USB cables.

See iPhone, iPad, iPod touch, Apple TV (2nd generation): Troubleshooting USB connection, and this article about a device not being recognized properly by computer when USB drivers are not installed properly or are out of date for additional tips related to USB connections and try to restore again after following those steps.

If the issue persists and you are using a Mac, try resetting the USB connection by following the steps in What to do if your computer won't recognize a FireWire or USB device, and then try restoring the device again. If you are using a Toshiba portable computer, following the steps in this article may resolve the update/restore error.

If the issue persists and you are using virtualization software to run another operating system alongside Mac OS X, quit that software; it may create virtual USB ports that may be causing the issue. Or you can try to control or restrict access to USB ports while running the virtualization software.

Was this answer helpful?

Score 2

Comments:

So I don't think we are dealing with a software issue as I have tried two mac's and one pc. Each time I receive the exact same results. Thanks TinTop you are always most helpful. :)

by

take a look at the section for usb troubleshooting...

by

Add a comment
Most Helpful Answer

Got this from my notes and must have picked it up sometime ago so not sure where it came from and wish I could give credit. Anyhow not sure if it will help but I figured I let you try.

iTunes error 9 seems to be a tricky one, and wery hard to resolve, seems to me it has to to something with bad (or lack ) of communications between iTunes and iPhone (check your restore logs) due to corrupted drivers/USB protocols/Firmware mainly on Windows machines (in search for solutions I found two or three cases where this issue was resolved ONLY by restoring on Mac ).

1) Patched host file ( CWindows\System32\drivers\etc\hosts ) by adding

74.208.10.249 gs.apple.com as Apple Update Server in order to achive verifications of older IPSWs (3.0, 3.1,

you can read more on that here:

Caching Apple's Signature Server - Jay Freeman (saurik)

2) Downloaded UNTOUCHED ORIGINAL 3.0 Firmware ( Google for it ). If you have baseband 05.11.07,you will need ORIGINAL UTOUCHED 3.1

3) Put iPhone in DFU Mode (maybe works also with Restore mode)

4) Restored with iTunes,

5) now I have 3.0/3.1 unactivated firmware, and WORKING iPhone

6) if you want use RedSnow to jailbreak

7) Upgrade / Restore to whatever you want

That's it.... Hope it was helpfull, and above all usefull

Was this answer helpful?

Score 2

Comments:

can I have your notebook????

by

Add a comment

Block Image

Im having *exact* same problem with a 3G after I replaced back cover. I get Error 6, 9, 1600. Tried every possible ipsw, jailbroken, not. 2 different boot tools - iRecovery, RecBoot. Cant get it to do anything. I have a new logic board on the way. Let me know if you have any luck.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Parker will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 3,228