Repair guides and support for LED, LCD, HD and other Vizio TVs.

255 Questions View all

Sound, backlight can be seen thru back cover but no picture

Vizio VT420M flat scren TV would come on with a "fuzzy color" then be okay after a few minutes. Now, I get only sound no picture. As I said, I can see the back light thru the back cover vent slots. Tried the flashlight tet but really couldn't see anything.

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Chosen Solution

@mrmike329 start of by checking all caps for obvious damage like leaking or domed appearance. If those check out okay you could try and check the voltages at the reg (U702) Count pins with the tab up and counted left to right.

Pin 1 0.00 volts

Pin 2 3.3

Pin 3 5.0

If those are the values that you get, you proceed to checking the fuses on the T-con board for continuity and voltage, you should get either 5 or 12V.

Block Image

""fuzzy color"" makes me strongly consider the T-con board as your issue. Let us know what you find. Also consider posting some high res images of your boards with your question. That would allow us to see what you see. For that use this guide

Was this answer helpful?

Score 2

Comments:

oldturkey03, great information! I will take the cover off and follow your advice. I will post the results here.

by

Add a comment

Add your answer

mike barber will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 22

All Time: 115