Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

1081 Questions View all

hybrid hard drive data recover

I had a second hard drive installed on my MacBook 13" mid 2012, a Seagate Mobile 1TB. It was booted through the main drive.

I was making a download straight to the Hybrid drive. Then I accidentally trashed the hard drive. It was just nighttime, and I left it downloading during the night. I came back to it next morning I couldn't access any data. I restarted the computer, and after a very long while, it just displayed the big "?" question mark sign on screen.

I tried again, and this time I interrupted the process. I then just extracted the drive, and computer came back to working normally, but now, when i mount the drive, it shows nothing, and unmount alone after a couple minutes.

I had critical data there, which I need to recover, but regular data retrieving software can't access it since it dismounts after a minute.

Does anyone has a solution for that ? Maybe a way to bypass the SSD part of the drive?


Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Answer

Chosen Solution

You maybe hitting a known issue with this series. You talk about adding a second drive so you replaced the optical drive for the second drive using a product like this: OWC Data Doubler. It makes no difference who's you used as they all face the same problem here. From the OWC Data Double notes:

  • MacBook Pro 13" models: Apple does not support the use of 6Gb/s drives in the optical bay. While we have observed a high rate of success using SATA 3.0 6Gb/s drives in Apple 13" bays where 6Gb/s link is present, some systems may not operate properly with this setup. For guaranteed reliability/compatibility, we suggest 6Gb/s drives be used in the main drive bay only, and 3Gb/s hard drives or SSDs be used in the optical bay when a two-drive configuration is desired. We cannot guarantee proper or successful 6Gb/s drive operation in the Apple MacBook Pro 13" optical bay.

You see the problem here is the optical drives SATA ports data rate is not a clean SATA III (6.0 Gb/s). So you need to use a FIXED SATA II (3.0 Gb/s) drive. The Seagate drive you have if I understand what you got is this: Seagate Laptop SSHD as it turns out this drive won't work either as unlike a fixed SATA II drive this drive has SATA auto sense technology so it is able to match the systems SATA port. In this case it's not able to correctly match the system port speed.

So what to do here??

You'll need to hookup the drive using something like this externally to get around the systems SATA port issue: Startech 2.5" SATA to USB adapter. Then you'll need to try to using a data recovery application like this: Data Rescue

If this is unable to gain access to the drive you'll need to talk to Seagate to see what they can do for you.

Update (03/21/2017)

First I agree with @mayer here replace the internal HD drive cable as I suspect it might have been the root cause of your problems with this drive! You don't want to use any drive in the bay until you do. MacBook Pro 13" Unibody Mid 2012 Hard Drive Cable Replacement & MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable

If you can get your self to an Apple Store or authorized Apple service center they will replaced it for free. You will need to have a drive in the bay though so think which drive you have on your shelf you can use. Do explain to them the SSD is the boot drive.

So at this point the SSHD drive just won't run when connected externally. At this point I don't think you have any alternatives here you'll need to sendoff the drive to a data recovery service. There they can use some special tools to recover your data from the drive. But that will be expensive! Are you sure you have no backups or have any way to recover from other sources the info that was one the drive? You might want to try that first.

You could try contacting the maker of the drive to see if they offer any guidance on how to proceed. Otherwise it sounds like the drive is gone here. Sorry ;-{

MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable Image


MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable


Was this answer helpful?

Score 3


Dear Dan , unfortunately that's not my problem .And i just double found that i the drive is not the sshd , it's a regular drive , but as you mentioned , a 6G/s usb3 one. My second drive , the one that failed , was installed in the main port , not the optical one , and worked fine for over an year. What happened it that I accidentally trashed the hard drive while copying that . i Think the problem was similar to accidentally pulling the cable of external drive during activity (that's how i lost most of my drives, but all of them could be seen and rescued with Data Rescue ).

I .already took the drive off , and plugged on external usb, but now, when i mount the drive, it shows nothing, and unmount alone after a couple minutes.

So it shows for just about a minute on Stellar , and then unmount itself.

. I will repost th question , but if you have any idea how to make this drive stay mounted , please let me know . cheers


No need to repost!

Your wording confused me Hybrid = SSHD.

Still not sure I understand the second drive you are using an external for your second drive is that correct? You still have the optical drive in place.


On this model, Apple will replace the hard drive/IR cable with no questions asked. The failure rate is that high.


No Dan , i had 2 drives installed on my macbook. One , installed in the optical bay , is a 256 ssd drive, still operating . The second one , installed in the main bay , was a regular 1tb drive , an ST-1000LM035 Seagate. Whan i took it out , i had another drive ,a Hybrid drive (SSHD) on my bench , so i thought that was the one that was failing ,when i posted que question.My bad.

So , 2 drives inside, the regular HD , in the main bay , failed. Now just the ssd inside, and when trying to connect the bad drive in external case, it mounts for just a couple minutes and dismount right after , so i'm not succeeding using rescue software.So my problem , unfortunately , is not the cable.


OK John I get it now!

Dual drive config as I had suspected (HD & SSD) HD was swapped out for SSHD. SSHD died.


Add a comment

Add your answer

john ribeiro will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 102