Model A1419 / EMC 2806 & EMC 2834/ Late 2014 or Early 2015 or late 2015 / 3.3 or 3.5 GHz Core i5 or 4.0 GHz Core i7 Processor / Retina 5K display

146 Questions View all

Installed new display, appearing as 3840x2160 instead of 5120x2880

Hi

Let me start by saying that if you can figure this out you're a genius....

I recently cracked the screen of my late 2014 5k iMac and had to shell out on buying a new replacement screen for it. The screen i purchased is this one:

http://www.ebay.co.uk/itm/27-Apple-iMac-...

I had a local repair shop install the new screen for me and its working fine however there is some weirdness which I can't for the life of me understand.

1. When i go to 'About this Mac>Displays' it lists the resolution as '3840x2160' instead of 5120x2880.

2. However when i go to system information in OSX it is listed as a 5120x2880 retina display.

3. If i go to 'preferences>displays' and click the 'default for this display' checkbox it switches it to a setting which 'looks like 1080p'. However on my previous screen when you clicked this checkbox it would use 'looks like 2560x1440'.

4. The scaling options and resolutions are different to what they were with the previous screen. My maximum resolution scaling i can select now is '3360x1890' whereas on my old screen it was '3200 x 1800'. '2560x1440' is also now classed as a scaled resolution.

Now i know most of this points towards the display not being the same, however it is the same from all the searching i've done. There have only ever been two versions of the iMac 5k to my knowledge, the late 2014 one (my one) and the late 2015 one.

If the display is not 5k why is it listed in OSX's system information screen as being 5k ?

One thing someone elsewhere mentioned is that 3840x2160 is the maximum supported output for external monitors connected to the iMac 5k... he suggested that perhaps via some bizarre circumstance the mac is thinking it's an external monitor and thus limiting its max resolution to 3840x2160 ? but then this doesn't explain why its listed as a 5120x2880 monitor in system information screen.

Thoroughly confusing, I honestly don't understand whats going on and was hoping someone here may be able to shed some light on it all.

Here are some images showing what i mean

about this mac>displays : http://oi67.tinypic.com/1567mkj.jpg

preferences>displays : http://oi65.tinypic.com/2q8byqf.jpg

system information : http://oi64.tinypic.com/6fmnit.jpg

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

4 Answers

Most Helpful Answer

I have tried a fresh install of multiple different versions of OSX and the issue remained.

I've pretty much given up any hope of fixing the issue,

Was this answer helpful?

Score 1

Comments:

Did you ever come up with a resolution. I have the same problem after replacing a damaged display on a 2014 27" iMac.

by

So I finally worked out what it was, and ultimately it was a case of having been sent the wrong screen part (TWICE !!!)

It seems lots of people on eBay are listing LM270QQ1 (SD B1) screens as LM270QQ1 (SD A2). SD B1 is the updated version of SD A2 but only supports 4k (ish) resolutions on the late 2014 iMac 5ks.

I spent a lot of time phoning up various places that claimed to have a LM270QQ1 (SD A2) in stock only to find out they were actually the newer updated version (SD B1). I eventually tracked down a SD A2 which the seller 100% confirmed was the correct one, I installed it and sure enough I got back the correct 5120x2880 resolution.

Hope this helps anyone with similar issue

by

Add a comment

Sounds like you got the wrong screen. Apple lists two different P/N's for this series. You need to use the same manufactures P/N as yours.

Hopefully you still have the original screen and can locate the lable on the back side to find the info to cross-check.

Was this answer helpful?

Score 0

Comments:

Hello.

I thought this may be the case but I have just got the part number for the original broken screen and its the same as the new one

LM270QQ1 (SD)(A2)

I really have no idea where to proceed from here :(

by

Add a comment

I am having the same problem - screen is showing as a 5K screen with correct serial number in the System report but incorrect in the "About this Mac" Dialogue box.

When showing the same image on another IMAC 5K machine and on the incorrect Idisplay machine - machine seems to be working at correct 5k resolution based on scale and size of objects and quality and zoom factor on image....

I think it might need a clean install but if anyone has any suggestions would like to hear them. Have posted both "about this mac" and "system report"

cheers Noel

https://ibb.co/fQz3MF

https://ibb.co/hCEETv

Update (03/21/2017)

I think its a software support issue for that new monitor type that we have installed and a software conflict - the monitor felt lighter than the old one when I installed it. did you try SwitchResX ? - be interesting to see if new OSx update fixes it - for all physical accounts the screen looks like it is functioning at 5k from what I can ascertain its just not updating the "about this mac" correctly

Was this answer helpful?

Score 0

Comments:

Did this happen after replacing a screen ?

I have tried doing fresh installs of OSX and it made no difference. My computer still displays 3840x2160 in the about screen.

Please let me know if you ever find a solution. I'll be so grateful :)

by

Add a comment

I just bought a new screen on ebay and it's as stated above. I got sent a SD B1 when I thought I ordered a SD A2 since the item description listed resolution of 5120x2880 but I only get 3840x2160. Luckily I had not applied any adhesive strips and can return for the correct one at the same price. (from a different seller) A hassle for sure but get the SD A2.

Was this answer helpful?

Score 0
Add a comment

Add your answer

SlackPanda will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 6

Past 30 Days: 36

All Time: 255