Printer claims there was no paper which is a lie

Canon Pixma MG5650: Printer fails to pull in paper and makes loud noises while trying. Error code: 1003 No paper.

However, I tried paper in different thicknesses, in different amounts, tried to push, to adjust, whatever.

Assuming some mechanical part is broken, how can I detect this myself and how could I possibly repair it? Canon's support in this, of course, is useless.

Thanks!

Ah btw, this problem just occurred all of a sudden, after having printed 15 out of 30 pages (duplex).

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

No not a lie! An alternative fact ;-}

by

Add a comment

1 Answer

Chosen Solution

Sounds like the pinch rollers are dirty with paper dust so they can't grab the paper. Using cotton swabs (Q-Tip's) and isopropyl alcohol to wash them down. See if that fixes things you may need to replace them if they are dried out.

You also will need to use some can'ed air to blow away the junk around the sensors as well.

Was this answer helpful?

Score 2

Comments:

Thanks for your tip!

I cleaned the pinch rollers and I blew away some (invisible) dust, but that didn't seem to be the problem. The printer would still not grab the paper.

However, when I was bored, I repeated this procedure again, four or five times, assembling, disassembling - and suddenly it worked again!

Only the gods know what happened here.

by

Add a comment

Add your answer

robby2905 will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 2

Past 30 Days: 4

All Time: 43