Skip to main content

Repair for speakers, stereos, header units, and CD players for your car or truck.

220 Questions View all

no sound, although radio works

2004 Toyota Avalon JBL stereo CD turns on stations change, but no sound

Any suggestions?

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Most Helpful Answer

@mssteffi start off by checking the speaker output connectors on your radio. Double check to make sure that all connections are properly made. You also want to check under the passenger seat. You will most likely find the power amp located under there. Make sure that it is connected right and all the wiring is intact. Check for any blown fuses in the fuses boxes. If yours is a stock amp check that pin 13 and pin 17 should have 12Volt. Use a voltmeter or similar to check on those. Let us know what you find. remember that a pictures is worth a thousands words. Just in case you have trouble with this, post some images with your question so we can see what you see. Use this guide for that.

Block Image

Was this answer helpful?

Score 3

Comments:

many thanks no idea there was a power amp under the seats wow

by

I found my speaker in the trunk had no connection on one side of the speaker wire hopping that was my problem . Soldered it back onto the speaker . Still im searching

by

Most likely your amplifier. Check under your passenger seat.

by

Add a comment

Add your answer

Steffi will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 6

Past 30 Days: 29

All Time: 2,476