Fifth generation of iPhone. Repair of this device is straightforward, and requires screwdrivers, prying tools, and patience. GSM/CDMA / 16, 32, or 64 GB / Black or White.

2881 Questions View all

Replaced Battery, will not charge even though it shows it is.

I replaced the battery on my niece's iPhone 4S, and attempted to charge it upon completion. Plugged it into a 1A charger and the phone didn't recognize that it, moved the usb to the 2A side of the same charger and it recognized it and showed that it was charging. Next morning the charge showed up less than when I hooked it up, but still showed that it was charging. Tried to reboot phone and hooked it up again to no avail. Tried separate charger and cable same issue. Any ideas would be greatly appreciated!!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

There may be a problem with the battery you replaced. If your device does not have the necessary electronic information that may be a problem with the charge integration, you can get help from an expert

Was this answer helpful?

Score 1
Add a comment

Thanks it was the new battery, replaced and fixed the issue!!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Doug will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 25