GoPro Hero 4 Silver only displays "HERO 4" on front screen...

Hero 4 Silver only displays "HERO 4" on front screen and shows no other functionality besides occasionally showing the red LED when powering up to the "HERO 4" front screen.

The rear screen does not come on. I have tried to do a hard reset by removing the battery, holding the power and shutter button for 10 seconds, and re-applying power while still holding the buttons until it powers on. I always end up at the same screen.

GoPro's PC software does not recognize the GoPro to do an automatic software update, and I have tried to do a manual update using the SD card with the "UPDATE" folder, but it still just sits at the "HERO 4" screen.

Any help or suggestions would be much appreciated.

Thanks,

Matt

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

I have this EXACT PROBLEM! My H4Silver begins to boot and then a moment after it shows any sign of life, IT FREEZES at the "Welcome Screen" that says HERO 4.....This is only on the front LCD screen Because the Touch Screen DOES NOT activate in any way.

My GPH4Silver has been amazing, I actually have !2x!Sil and 1 Black, but this one is a sad mystery...

PLEASE Give me some Good News...tell me you have received some sort of help from Ifixit or GoPro or other owners?!

I Have Done:

-Vetting of the battery and SD card using my other H4s and H4bk

-A Number of hard resets with no results...performed as so;

1. Remove (working) battery

2. hold menu(On) button and record button (front and top)

3. Re-insert battery while *Still* holding Menu(Power) + Record Buttons.

4. Welcome back to the "HERO 4" waiting screen

Note: I have performed this with or without an SD card,

I am at the end of my rope and my patience because I cant do much more without putting on scrubs and going into GP Surgery!!

Thanks!

J

by

i had the same problem. did you figure it out yet?

by

Add a comment