Laptop doesn't boot after upgrading RAM

Hi.

I tried to install 8GB RAM instead of 4GB. When I finished the replacement, I turned on my laptop, but the screen stayed black, no Dell logo or anything, no signs of booting at all (all the indicators were off). After 10-15 seconds it turned off by itself. After that the HDD indicator started blinking, and the other two indicators turned on.

Then I removed the new RAM and installed back the old modules. But I got the same problem - the laptop doesn't boot, there is no Dell logo. I tested both sets of RAM modules on my other laptop and they work.

How do I fix this?

P.S. I followed general recommendations and removed the battery before each procedure.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Turned out I was supposed to remove the CMOS battery (and press the power button for a 10 second) after upgrading the memory. It's described on the Dell website http://www.dell.com/support/article/us/e...

It works now!

Was this answer helpful?

Score 0
Add a comment

Can you connect an external monitor? This checks to see if you just knocked the video cable loose.

Do you hear any beeping? If there isn't any, its likely not the RAM.

Was this answer helpful?

Score 0

Comments:

I was very careful and didn't touch anything beyond the memory modules. It's not my first time, so I'm pretty sure I didn't cause any physical damage.

When I press the power button, it beeps, the DVD drive turns on, but that's it.

by

Just a single beep or a pattern of beeping?

I know this laptop well. The RAM slots are very close to the CPU. I would also suggest checking if that was knocked loose. I know you said you are very careful, but stuff happens.

by

Add a comment

Add your answer

Serhij Sokolenko will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 2

Past 30 Days: 16

All Time: 43