Released June 2012 / Core i7 processor with Turbo Boost / Up to 1 GB DDR5 Video RAM

283 Questions View all

Replacement airport card (BCM94331PCIEBT4CAX) will not turn ON

The Airport card in my Macbook has become intermittent so I ordered and fitted a replacement, BCM94331PCIEBT4CAX.

When the MacBook powers up the WiFi status indicates WiFi is OFF, attempting to turn it on silently fails.

System Report -> Network -> WiFi lists the Airport card, with status OFF.

The only difference between the listings for original and replacement Airport cards are :

Locale FCC (orig) / RoW (replacement)

Country Code XO (orig) / GB (replacement)

My MacBook was purchased in the US, the replacement AirPort card was bought in the UK, where I'm located.

The wifi log file shows the following :-

Sun Jan 29 00:08:18.203 <kernel> AirPort_Brcm43xx::platformWoWEnable: WWEN[disable]

Sun Jan 29 00:08:46.363 <kernel> wl0: powerChange: *** BONJOUR/MDNS OFFLOADS ARE NOT RUNNING.

Sun Jan 29 17:12:19.996 ***Starting Up***

Sun Jan 29 17:12:21.084 <kernel> Unable to create IO80211InterfaceMonitor

Sun Jan 29 17:12:21.084 <kernel> Unable to create IO80211InterfaceMonitor

Sun Jan 29 17:12:21.084 <airportd[69]> airportdProcessDLILEvent: en1 attached (up)

Sun Jan 29 17:12:21.092 <kernel> Setting BTCoex Profile: band:8

Sun Jan 29 17:12:21.092 <kernel> Profile[0]: mode:7; desense:0; desense_level:0; chain_power_offset:<kernel> 0,<kernel> 0,<kernel> 0,<kernel> 0,<kernel>

Sun Jan 29 17:12:21.092 <kernel> Profile[1]: mode:7; desense:0; desense_level:0; chain_power_offset:<kernel> 0,<kernel> 0,<kernel> 0,<kernel> 0,<kernel>

Sun Jan 29 17:12:21.092 <kernel> Profile[2]: mode:7; desense:0; desense_level:0; chain_power_offset:<kernel> 0,<kernel> 0,<kernel> 0,<kernel> 0,<kernel>

Sun Jan 29 17:12:21.092 <kernel> Setting BTCoex Profile: band:2

Sun Jan 29 17:12:21.093 <kernel> Profile[0]: mode:0; desense:0; desense_level:0; chain_power_offset:<kernel> 0,<kernel> 0,<kernel> 0,<kernel> 0,<kernel>

Sun Jan 29 17:12:21.093 <kernel> Setting BTCoex Config: enable_2G:1, profile_2g:0, enable_5G:1, profile_5G:0

Sun Jan 29 17:12:21.205 <airportd[69]> _bsd_80211_event_callback: Failed to get power setting from device : err -3900

I checked and recheck installation and eventually refitted original AirPort card, which worked, but only for a while as it's become intermittent.

I'd appreciate and insight into how I can fix this issue.

Thanks.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

I'd give a try in reinstalling the Os if I was you. I imagine you have already tried a Pram reset. Be aware that the wifi module reinitializes when you turn off the mac, as a reboot by itself is insufficient.

Was this answer helpful?

Score 2

Comments:

No, I've not tried Pram reset, didn't know of it.

I will refit the replacement AirPort card and give pram reset a try.

I'll feed back the results on this thread.

Good point about the wifi module only reinitialising following power off, I did try power off, the problem remained.

Thank you.

by

Excellent, after resetting the PRAM, the replacement AirPort card just works.

Thank you very much Arbaman.

by

You're most welcome..glad I could help :)

by

Add a comment

Add your answer

Paul Wilkinson will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 5

All Time: 133