The Apple iPhone 5s was announced on September 10, 2013. Repair of this device is similar to the previous models, and requires screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Silver, Gold, and Space Gray.

3762 Questions View all

Error 9, need to recover data.

My own 5s decided it was going to go into a boot-loop. I was playing Egg,Inc (it is the best game ever) and my battery died. i plugged it in and a half hour later i returned to a iPhone 5s at the apple logo, but them i found out it was a boot-loop. Before it would boot up if the front camera cable was unplugged, but that doesn't work anymore. I really need to recover data from it. When i update, it shows error 9. Same with restore. it will say extracting, preparing, waiting,preparing,waiting, then it will fail. How could i get it to power up one last time to backup my game? Ive already tried heating the nand, putting pressure on it, etc. and it still wont restore/boot up. ive tried to update/restore without lcd and it still does this. Please help!


Now it does not turn on after heating the NAND. PP5V0 and VCC_MAIN are both there. This thing is probably screwed up beyond repair.

Answered! View the answer I have this problem too

Is this a good question?

Score 3
Add a comment

1 Answer

Chosen Solution

I was going to say, sadly too late, that heating NAND's or any other IC is generally not a good idea.

When you heat an IC, the heated solder balls expand. When there is underfill involved, it holds down the IC rather than let it float up on the expanded solder balls. The expansion has nowhere to go and they can either short out amongst themselves or explode out from underneath the IC. If you see tiny solder balls around the NAND, then that is why.

Were you using a genuine Apple Lightning cord?

There could be problems with one of the power rails. (there are dozens of rails in an iPhone), specifically the NAND related one. It could be a defective NAND or just a bad connection, in which case you could remove the NAND, clean up the underfill, reball the IC and re-install.

Was this answer helpful?

Score 2


I tested the voltages and they are there. The phone actually was on; just in DFU mode. Now I just need it to work, I don't really care about my game anymore. I am restoring and will tell you if it works.


Also yes it is a genuine Apple cord, it use it for my iPad too.


If I Reball and reinstall the NAND, will my data be there?


It just gave error 4005, it's on the same page as 9 on the apple website. Guess everything is pointing to the NAND now...


After cleaning underneath the NAND and desoldering it, I need to solder it back on but ran out of flux... Figures. It looks very clean though, also figured out why the gyroscope/compass didn't work, U18 was missing and I think it was making everything else not working right.


Show 2 more comments

Add a comment

Add your answer

Gigabit87898 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 13

All Time: 317