Broken phone - GPS/Network dead

Long story short, I was having a problem with my camera, so I whacked the phone on the palm of my hand a couple times (yeah, that might help! [lol]) and after that I lost the GPS and network.

I am on T-Mobile running Android 7.1.1.

I cleared the cache, tried different combo's of network settings (2G, 3G, 4G LTE), rebooted in safe mode, cleared the network settings, etc. Nothing has worked. I get Wi-fi but no T-Mobile network bars (the triangle is blank) or GPS.

I've opened the back of the phone previously to replace the glass (as a glass+frame module) and battery and everything worked fine after reassembly.

Someone on another forum suggested look at the antenna connections and pointed to the photo here on iFixit.

When I popped the back open and looked closely at the connectors on the upper right side of the phone (looking at the phone with the back off), I could see that one of the connectors in the duo pairing was bent. Also the single connector below the duo connectors on the right side also looked a bit bent.

I straightened these connectors and they looked good to me afterwards.

However, I still get no GPS or network. Wifi works fine

Is there a Nexus 5x service manual available? Could anyone suggest (would need clear instructions) anything else to test? Maybe I broke a solder connection? Everything looked tight to me when looking through a magnifying glass but I don't really know everything I am looking at inside the phone.

I'd hate to have to buy a new expensive mainboard to save this phone!

P.S. Here is a link to some photos of the damaged clips before I repaired them:

pre-fix antenna connector photos

Answer this question I have this problem too

Is this a good question?

Score 0

1 Comment:

What kind of problems were you having with your camera that made you whack it??! All jokes aside, you might have broken something especially if you used a lot of force when trying to fix your camera problems. I can't really suggest anything since I haven't had these type of problems myself so that's why I commented rather than answered.


Add a comment