Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

725 Questions View all

New SSD, SATA w/ intermittent functioning, but mostly get "?" folder.

Macbook Pro 13" 2012-ish, hard drive failed, so put in a new SSD, loaded OSX onto it and it all worked briefly, but after a few days I suddenly got the "?" folder and nothing would fix it.

So, I then installed a new SATA cable from iFixIt, but now the drive isn't even seen when I boot into recovery and look for it using Disk Utility. For fun, I put the old SATA cable back in and every booted perfectly, but after a few minutes of working the computer froze. Upon rebooting I was back to the "?" folder. Tried the new SATA cable again and...nothing.

I saw a Youtube video of a guy who used electrical tape to cover the old SATA cable and keep it from shorting. I tried that also. Nada.

I'm about out of ideas. Any thoughts would be greatly appreciated

Thanks in advance!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Contact either an ASP or Apple store and ask if they are aware of the free replacement program for the hard drive/IR cable. Get it replaced.

I put the old drive back in before taking it to Apple, then ask if that cable killed your hard drive (which it actually did).

What, exactly, new drive are you trying to use?

Was this answer helpful?

Score 3
Add a comment

Add your answer

Patrick Thurber will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 34