1.7 GHz dual-core Intel Processor (Turbo Boost up to 2.6 GHz) with 3 MB shared L3 cache

82 Questions View all

After replacement both new and old batteries won't charge.

My MacBook Air battery capacity got very low over time (Coconut battery has shown around 42% of design capacity). So I decided to replace it, I ordered replacement battery on eBay.

After installing the battery the computer booted up and has shown 0% to 1% of charge, I thought that the battery is discharged and left computer to charge for 4-5 hours.

After that I opened the computer and was surprised to see that the charge remained the same - 0% to 1% (I was regularly checking the computer and throughout the "charging" period the charging indicator was always amber). After plugging the charging cable out computer shuts down immediately and turns automatically on when charging cable is connected back.

I tried to do SMC/NVRAM reset after that, which didn't help. Also I tried to put old battery back (which had 61% charge at the time) and it also stopped charging - charging indicator is amber, but percentage stays the same and Coconut Battery shows "Charging with: 0 Watts". I tried to reset SMC again, but the problem remained. On old battery it doesn't turn off if I disconnect charging cable, but obviously then battery starts discharging and I have no way to charge it up.

Now I'm left with a laptop that doesn't work correctly with both batteries.

Also Coconut Battery screenshot with new battery installed.

Does anyone know how to fix this?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

I would start off doing a SMC reset. Follow this Apple TN: Reset the System Management Controller (SMC) on your Mac.

Coconut is reporting the charger is connected but not charging which could also imply the charging logic is damaged on the logic board. Did you follow proper ESD protection? You might have Zapped something.

Was this answer helpful?

Score 2

Comments:

Thanks for the reply, but as I stated in the question I already did SMC reset multiple times. While doing replacement I followed ESD protection.

by

As you lumped it together with NVRAM just wanted to be sure you had.

by

Add a comment

Add your answer

juri will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 47