The first Legacy was available at Japanese dealerships on February 1, 1989, with worldwide distribution starting in 1990.

14 Questions View all

93 Legacy non-turbo engine turns over but no spark, injectors working

engine turns over but no spark, injectors working which rules out the crank sensor, coil metered within limits. was going to change control module as it is of the rare few the auto parts stores cannot test. not sure what the camshaft sensor does when it goes bad? not sure of other problems it could be?? would appreciate some accurate diagnosis on the problem. thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

currinmarco , Have you scanned/retrieved any trouble codes as this would be the first step to try and pin point the fault. If you could, some of the auto parts suppliers offer free code reading like Pepboys, Nappa, Advanced auto parts,etc and some of the guys are very knowledgeable and may have seen the issue often and put you on the right track. One quick check coolant temp sensor to make sure it is plugged in, sits under plenum could cause no start condition. Posted some trouble shooting links for you to checkout below. Good luck.

I hope this helped you out, if so let me know by pressing the helpful button.

http://www.aa1car.com/library/no_spark.h...

http://www.ultimatesubaru.org/forum/topi...

https://www.youtube.com/watch?v=YBE7c7lf...

http://www.troublecodes.net/subaru/

Was this answer helpful?

Score 1
Add a comment

Add your answer

currinmarco will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 10

All Time: 28