POSIX reports could not format the drive

Hello,

I cannot install osX on it. I've tried yesterday.

I'll try to explain you :

  • 2010 : I've bought the MacBook Pro
  • 2010-2016 : everything was OK
  • Apr 2016 : The Mac was having problems
  • May 2016 : I've bought a 500 GB Samsung HD drive
  • Jun 2016 : Clean install of Snow Leopard was OK. But, when the update to Captain was installing the Mac went into sleep mode and wouldn't work until I restarted the system.
  • Jan 2017 (yesterday) : I've broken my girlfriend's PC!

Jan 2017 (yesterday)

I've bought a Crucial 525 GB SSD SATA III (6Gb/s) to replace the older drive

In trying to install from the Snow Leopard CD. The window where to choose the drive to install the OS was empty, Went into Disk Utility and impossible to format the drive. Posix reports ... bla bla bla!

I've put the old hard drive back into the system and it was OK, I've installed Snow Leopard on it. I then format the SSD using an external connection I put the SSD back inside the Mac, The Mac saw it this time and after 1 minute the Mac told me: "impossible to install Mac OS on it"

Ok... AND THE BEST COMES NOW :

I put my hard drive with macOS on it (the one which was working perfectly 1 minute ago) and nothing. The round with the bar inside to tell me I'm a loser.

I don't understand and I really need help. Thanks a lot :-)

Update (01/10/2017)

Hello Dan.

Thanks a lot for your answer.

It's a mid-2009 13 inch bought in Sydney's Apple Store. The sata wire is a "821 - 0814 - A" on it.

I've check all the connectors and also Ram. Everything looks good. I just broke a part when I was checking. It's a small piece on the motherboard where is written "TDK -213HF - 0931Y" the electronic of this part looks ok, I broke the plastic on the top. The Mac started after my bad intervention. This part is on the right top of the mother board when you have the battery close to you. Of course with the bottom on the top.

Here is a pic :

Block Image

EDIT : fixed with tape...

Block Image

Update (01/10/2017)

Thanks a lot Dan !!

OK cool for the TDK chip issue! I mean, when the Mac will be fixed :-)

For the SATA, the reseller told me there is no problem. I'll give him a phone call tomorrow, he's not here this afternoon but he told me, there is no problem of compatibility... I will show him this thread.

For the SATA I, II, III question, I've tried this :

With the original hard drive (Samsung 250 GB SATA II) even the C touch during the boot, a picture with a folder comes and the CD comes out.

With an after market hard drive (Hitachi 500 GB SATA II) the installation starts and one minute after a window comes and told me "there is a problem during the installation, the installation has stopped, you must restart and try again, please contact your editor...)

With the Crucial 525 GB SSD the same as with Hitachi after market.

The installation was OK yesterday on the original Macintosh disk but after I put it out to install OS on the SSD, it would not restart.

I don't understand at all

Update (01/10/2017)

Yep, items hard to explain in English.

To be simple, I want to use the ssd drive and the other ones I use was for testing.

It's not working on all drives (sata 2 or 3).

And yes, I've the CD-ROM of snow leopard.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Can you give us the exact model of your system. If you can still see the serial number on the case you can try looking it up here: EveryMac - Lookup

by

Add a comment

1 Answer

Chosen Solution

From the sounds of it I would suspect your SATA drive cable is bad.

Depending on your systems age you might be able to get Apple to replace it for free. If not we can guide you on the correct part to get and how to replace it.

Update (01/10/2017)

OK, well you have a different problem than what I suspected!

Your system's SATA ports are SATA II (3.0 Gb/s) your Crucial MX300 SSD is a fixed speed SATA III (6.0 Gb/s) drive. Sadly, this drive won't work in this system. I've pasted your system & SSD specs above for reference.

The systems SATA speed dictates what the drive can be. You need either a fixed speed SATA II (3.0 Gb/s) drive or one that has auto SATA speed sense technology to match to your systems SATA speed. As an example looking at this SSD spec sheet: Samsung SSD 850 EVO we can see the drive is able to work in all three SATA speeds SATA I (1.5 Gb/s), SATA II (3.0 Gb/s) & SATA III (6.0 Gb/s) so it would work in your system. What ever drive you get needs to have SATA II (3.0 Gb/s) listed in the spec sheet if not move on to a different drive for this system.

Update (01/10/2017)

Not sure I follow your logic here??

Holding the C key during the boot up process is to select an external install media. The better way is to use the Option Key to gain access to the Boot manager to then select which drive you want to use to boot up from. Given the fact you are moving around with so many drives you really need to use the Option Key method.

Lets focus on one drive here (either of SATA II HD's), which one is it you want to use? And do you have either the original grey CD/DVD that came with the system or are you using the retail version of the OS-X (with the picture of the Snow Leopard on it)? For now forget about the SSD as it just won't work here.

Update (01/10/2017)

I thought both HD drives where SATA II (3.0 Gb/s). If not don't waste your time on the SATA III (6.0 Gb/s) drive. Until to get another SATA II (3.0 Gb/s) drive you're not going to get this puppy working.

In the mean time if you have access to another Mac why don't you create a bootable OS install drive using a USB thumb drive (16 GB). I find this a lot better than trying to work off of a slow CD/DVD disk. Besides, you can then use a newer OS version.

Here's how: How to make a bootable OS X 10.11 El Capitan installer drive. Given the systems age I won't go any higher unless you boost its RAM to 8 GB.

Was this answer helpful?

Score 2

Comments:

As for the TDK chip it's the Ethernet port filter so unless you are connecting to a wired network you should be fine. If you do need to hook up over the network you may encounter problems if there is any damage internally.

by

Great. Thanks a lot.

I'll try everything you told.

I don't have an access to an another Mac until next week.

I'll let you know.

Many thanks.

Regards.

Nicolas.

by

Add a comment

Add your answer

Couscoussiere will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 85