The Apple iPhone 5s was announced on September 10, 2013. Repair of this device is similar to the previous models, and requires screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Silver, Gold, and Space Gray.

3062 Questions View all

Compass and Motion sensor not working after full reassembly

UPDATE 2

I tested the sensors using the sensor kinetics app from the app store. This shows it seems that all sensors are dead. So maybe M7 is damaged as it was also pointed out Screen orientation won't rotate after LCD/digitizer replacement? by @tomchai. As this phone had a water damage, my last try is going to be to drown the logic board in 99 % isopropanol for some minutes and brush it gently with a soft brush. Hope this helps. Doesn't have any further ideas.

________________________________________________

UPDATE

Removing the top right screw of the flex cable holding bracket did NOT solve the issue. Reading from iPhone 5 compass does not calibrate or move. that the standoff screw right under it might got magnetized by screwing in a magnetized one and removing that one, too didn't solve it neither.

I also just have done a factory reset and set it up as an new iPhone. Still doesn't work. So it doesn't seem to be a software issue either. Also tried changing the compass to use Magnetic North instead of True North. Did not work, too.

Also tried now leaving the flex cable shield including it's screws out completely which also didn't help. Really running out of ideas now.. :(

________________________________________________

Hey guys.

Just this night I finished completely reassembling an iPhone 5s 16GB (rose gold) distributed by a friend of mine from the scratch. I bought a new chassis (silver) and with this was forced to buy new flex cables and also bought a new touch screen. So in the end the only things i kept are the logicboard and the back camera I guess (Screen was missing whole except the touch ID).

After the first screen was broken I'm now more than happy that >>almost<< everything seems working fine.

So I used the "Phone Diagnostics" app from the app store to confirm everything's working and received a fail for compass and motion sensor. I could confirm this via the compass app which doesn't react to any movement of the phone at all. As it was needed I bought a complete screw set for it. I noticed on the iFixit guides that there should be a non-magnetic standoff and screw on the top right off the phone if I remember right. I got the standoff from the old phone and reinstalled it in the same place but unfortunately I could not find any fitting non-magnetic screw for the exact same place so I used a normal one. That's the only issue I could think of at the moment.

Any tips about what I could try to fix it or ideas where I could have &&^&@@ it up?

Thanks in advance.

Best Regards,

Eddga

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Originally the demagnetized phillips screw should be in the top right screw hole for the metal plate that covers the screen cables.

by

Add a comment

1 Answer

Chosen Solution

I would take the screw out and test the compass. If it works when the screw is removed, then you found your problem.

There should be a non-magnetic screw in your set. Just test with a magnetized screwdriver to see which on doesn't "get attracted".

Otherwise, you could probably leave the screw out without any issues or salvage one from a dead phone.

Was this answer helpful?

Score 1

Comments:

Yeah I tested that when I poured all the screws out of their bag and run with my magnetized screwdriver through all of them. Except for the also non-magnetic standoff screw which is located below the one we talk about and provides the thread to screw that one in, every single screw stuck to my screwdriver. So it seems it has been missing in the set.

I'll contact the seller and maybe leave it out at first. Was not sure if this would cause any further issues. So thanks for the info and clarification.

by

So now operation is done. Result is that leaving the said screw out does NOT solve the issue unfortunately. Compass app still unresponsive to any movement.

by

Add a comment

Add your answer

Eddga Matsson will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 6

Past 30 Days: 7

All Time: 38