Camera not working. No hardware found.

After tearing the whole Mac apart and putting everything back the camera hardware can't be found.

I never had this problem before, always careful with everything.

Maybe the camera was already broken, don't know and don't want to ask the customer yet.

Got the cable out of it socket 3 times now but no go.

Also attached my external hdd with OS X to see if it's not a software problem but still the same.

Mac came to me because of overheating and a dying fan.

Anyone an idea for what to try next?

Thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

I'm assuming you've already done SMC and NVRAM resets, and you've also reseated the connectors.

I would assume that the camera module is dead as a first hunch. When dealing with the small camera assemblies, especially in iPhones and Macs, it's easy to overbend the camera ribbon cables and break one small trace.

Was this answer helpful?

Score 2

Comments:

I've looked in the logs. Seems like the camera hasn't worked for a while.

I'll ask the customer tomorrow.

Thank you for your response

by

Add a comment

Add your answer

Nathalie Spoor will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 4

All Time: 48