Released April 2010 / 2.4, 2.53 GHz Core i5 or 2.66, 2.8 GHz Core i7 Processors

488 Questions View all

MacBook Pro still won't charge after replacing everything.

Okay so a few weeks ago I was brought a MacBook Pro 15" Unibody Mid 2010 with a faulty logic board that needed to be replaced. I did no testing on the logic board but i was told that Apple themselves diagnosed it as a bad Logic board. So I purchased a logic board off of this site because it would be cheaper for me to do it than have Apple do it.

After replacing the logic board, initially when first trying to get the thing to boot, I noticed that there would be really faint clicks and the indicating light would blink slowly and consistently. After doing an SMC reset I got it to boot, but the cpu and gpu fans would run max speed and the indicator light on the MagSafe charger stays green, never goes to the Amber charging color. Anytime I went to reboot or remove it from the power adapter, I'd have to do SMC reset to get it to boot up. I figured this all had to do with having a bad/old battery since it wouldn't take a charge.

So I ordered a new battery off of here, thinking that would fix the weird power issues. As I was waiting for the new battery to come in the mail, I talked to the owner and he decided he wanted to put in a new Samsung 850 Evo SSD 500gb. I cloned and got the new hard drive installed with no issues besides the current power/no charging issues.

After receiving the new battery, I immediately installed it and just for the sake of trying it, I booted the Macbook up without being plugged into power, only on battery power. Booted just fine, no issues, no fast fans, didn't have to SMC reset, battery read at 61% and correctly saying that it wasn't plugged into the wall. I then plugged it into the wall.... No amber light, just a green light and the battery indicator on the home screen at the top says, Not Charging.

I tear everything apart again, put it back together, clean the magsafe port after removing it completely. Reassemble. Boots no problem but still says Not Charging. Slowly but surely throughout me trying to fix the issues the battery goes all the way down to being dead. Not once could I get it to charge. So after reading a little more online I decided I might as well replace the MagSafe DC-In board as well. Part is cheap and it was the only power related part that I hadn't replaced since the new logic board didn't come with it and I salvaged the one off the old one.

The MagSafe DC-In board came in today and I replaced it and still no amber light. No charge, can't get it to boot without SMC reset. Automatic shutdown on taking off of power. I left plugged in over the weekend, seeing as some people said it does charge but just really slowly. But still no charge. One strange thing is that with the new battery, once I get it booted, there is no battery symbol at the top of the desktop. When I go to power settings and check the box to get it to display, it shows up for half a second and disappears. With the old battery, for the most part the battery symbol will be there but with a black "X" through it.

Another strange thing is with the Original/Old Battery, If I do this exactly I can get it to boot up like it has a charge although only at 1% and still no charging symbol/amber light. But if I turn it off completely, unplug power from wall while still in the MBP, wait a few seconds and then unplug from the MBP, wait a few more seconds, plug back in to magsafe port, then plug it into the wall, it will boot up automatically with quiet fans. Get to the sign in page and the symbol is at the top saying 1% but not charging. It has a the power bolt through the symbol, and I can pull up the power tab on About this Mac and it gives me all the information about the battery. It won't do that with the new battery at all. Follow that to the T and it will only sit there with the low dull click and blinking light until I do a SMC reset to get it to boot.

Almost forgot but I've tried with other chargers/power adapters, tried with different outlets, made sure this power adapter works on other Macs and I've ruled it out from being the culprit.

I've read countless forums on the subject, can't get anything to work. Only thing I can think of is maybe I got a bad part. Any advice would be greatly appreciated, as long as you don't tell me to SMC/PRAM reset like every single forum does.

TLDR: Replaced Logic board, battery, MagSafe DC-in Board, countless SMC resets and still wont charge. Not power adapters part. Maybe got bad replacement part?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

3 Answers

Chosen Solution

First let's geta better idea of what that battery is doing. Download this free app and run it and let us know your results: http://www.coconut-flavour.com/coconutba...

FYI the most common issue on this machine is a bad hard drive/IR cable. I use the 2012 cable for a replacement: MacBook Pro 15" Unibody Mid 2010 Hard Drive/IR Sensor Cable Replacement

MacBook Pro 15" Unibody (Mid 2012) Hard Drive Cable

MacBook Pro 15" Unibody (Mid 2012) Hard Drive Cable Image

Was this answer helpful?

Score 2

Comments:

Coconut doesn't come up with any information since the MBP doesn't even read that there is one plugged in. As for the hard drive cable. It boots to the HD no problem. What would that have to do with the things ability to charge?

by

Add a comment

This is marked as solved and I see no answer??

Was this answer helpful?

Score 0
Add a comment

Ever figure this out? Im having the same problem. But what the above guy said about the HD/IR Cable made me intrigued. Because my cable actually is not fully screwed in where the "grounded" part is (2 loop holes flanking the ribbon midway between HD and logic board. Because i lost those screws but thought it was just for fastening. Could it have some electricity functionality to it thats affecting charging through the DC in?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Corey will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 19

Past 30 Days: 71

All Time: 648