Repair guides and support for Panasonic's Viera line of televisions.

75 Questions View all

TC-P50S30 Won't turn on. No red light.

Hi

I noticed the standby light was blinking and didn't think anything of it. I pressed the power button and it stopped. Then I noticed it again. Not thinking much of it, I unplugged the tv and plugged it back in after about ten minutes. Unfortunately, I didn't know at the time that you can count the blinks for an error code. Sort of a moot point since I cannot proceeded a number of blinks other than the fact that at least there were blinks prior. All I can say is that if I hold the power button in for say three to five seconds I hear a click but that's it. No power light or even the slightest flicker, just the sound. And idea on what board I can check? I'm confident that I can replace a board, but want to be sure I buy the correct one. Thank you!

Here's a picture of the P board, A board, A1 connector showing only 7 pins, and the flow chart I was following. I'm confused by this because the flow chart says to momentarily ground pin 8.

Block Image

Block Image

Block Image

Block Image

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

3 Answers

Chosen Solution

After buying a new power board, the TV didn't work and all voltage readings were the same, so I ruled out my power board and put it back in. The issue was with the A board....the main board (TNPH0914) suffix AC in my case. After replacing that board it works fine! I kept the old A board, so if I figure out what exactly went wrong, I'll come back and post the fix if it's possible.

Was this answer helpful?

Score 1
Add a comment
Most Helpful Answer

@djodts start by checking things out as directed on the flowchart. To check the fuses you will need a multimeter and check fuses for continuity

Block Image

Fuses are outlined on this one

Block Image

It might also help if you take some good pictures of your boards and post those with your question. That way we can see what you see. Use this guide for that

Was this answer helpful?

Score 2

Comments:

Thank you. The fuses are good. I did find a flow chart that said to check the P6 cable (pin 1) for 3.2v when pressing the power. I didn't pick up any voltage, so the chart said to go to A1 on the A board and ground pin 8 momentarily, but there is no pin8... There are only 7 :( Any other thoughts? I'll post pictures of both my P board and A board. Thank you again!

by

Hi @djodts

Just a thought. Are you certain that you have the correct flowchart for your particular board?

Have you verified that the flowchart is for your particular model by checking that your A board number, chassis number, model number etc matches the flowchart reference.

by

@djodts looks like pin 1 is the panel on. that will only work if the rest of the voltages are okay. Let us know what you get by measuring the rest of all the contacts on P6. Keep in mind if you do not have any standby voltage, you got nothing.

by

@oldturkey03 thanks. Here's what I found on each pin. I have two columns. The first is the voltage after plugging the tv in. The second column is the voltage after pressing and holding the power button for about 4 seconds. For what it's worth, I hear the relays click when I plug the unit in and then if I press and hold the power button I hear them click again. Further, the digital audio (optical) connection is illuminated red until I press and hold the power. Just trying to give as much info as I can. So, here is the data you asked for:

Pin1 .002 ; -.000

Pin 2 .002 ; -.000

Pin 3 .003 ; -.000

Pin 4 -.001 ; -.000

Pin 5 .024 ; .028

Pin 6 4.9 ; 4.9

Pin 7 2.96 ; -.000

Pin 8 -.001 ; -.000

Pin 9 -.001 ; -.000

Pin 10 15.63 ; progressively decreases after I press the power, but not instantly

Pin 11 15.61 ; same as above, progressively decreases

Pin 12 -.001 ; -.000

Pin 13 .995 ; progressively decreases

Pin 14 -.001 ; -.000

Pin 15 .995 ; progressively decreases

by

@djodts Do another check. Pin 12 should be ground same with pin 14. What voltage do you have when you measure either 12/13 or 14/15 or 12/15 ? Right now it looks like you are missing power coming from the board.

by

Show 3 more comments

Add a comment

Hi @djodts

Here is a link to the service manual for a Panasonic TC50OS30 / GPF14DU Chassis TV.

http://elektrotanya.com/panasonic_tc-p50...

To download the file wait until the sentence below the Document preview box chages from This file is downloadable free of charge: ...processing... to This file is downloadable free of charge: Get Manual and then click on the Get Manual. This is the download link. Be patient it takes a few minutes to find the file.

Here is an image from the manual showing the A1 connector on the A board in circuit. It shows what you have i.e. 7 pins.

Therefore, are you sure that you have got the correct flowchart for your TV? Click on the image to enlarge it for better viewing.

Block Image

Was this answer helpful?

Score 2

Comments:

Thanks for the link. The troubleshooting guide on that manual shows to check the fuses if there is no power or blinking lights. I've already checked the fuses and they are good. The next step on the guide is to check the A board, but there are no detailed instructions on how to do that/what specifically to check.

Thanks

by

Add a comment

Add your answer

Doug Jodts will be eternally grateful.
View Statistics:

Past 24 Hours: 10

Past 7 Days: 77

Past 30 Days: 197

All Time: 1,472