Announced on September 9, 2015, the iPad Mini 4 maintains the power of an iPad Air 2 in a smaller form factor.

40 Questions View all

screen issue , wont show anything

Hi everyone ,

let me explain the problem,

so i wanted to repair my iPad mini 4 the screen was broken.

so bought an screen and when i connected the screen the 'sleep' button didn't wanna work.

no problem i know that it's an issue with the soldering or somthing so i send the screen back.

ill get a new screen now the problem is when i power on the ipad , it shows a quick 2 sec apple logo then nothing to see on the screen.

noticed when i try to 'play' with the power and home button it show the start screen but again also for 2 sec.

im out of ideas so can any explain?

is it a bad screen again or did i broke something?

****UPDATE****

Nothing worked ,

A prof checked the ipad on motherboard damage and he noticed that some of the 'ic's ' burned.

so i guess i made some short circuit. ouch :(

Now the iPad works again but still the 'sleep button' not.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Hey briiangullentops,

Where did you buy the screen?

by

partservice.eu

they use oem (or atleast thats whats on the box

by

It could be bad parts or maybe you accidently do somthing wrong during the repair.

by

i guess i did something wrong originial broken screen has the same issue now .

%#*@ , time for a board repair

by

Add a comment

2 Answers

Chosen Solution

Plug the iPad into iTunes and check if it is in DFU mode because it could be if the screen is on a black display but turned on.

Was this answer helpful?

Score 3
Add a comment

I had what may have been a similar issue after replacing the LCD. Have you tried the "erase all content and settings" option? On mine, the iPad would power up OK, but after powering it off, the next time during powering on the Apple logo would appear, but then the display stayed dark. I could tell that the power was actually on, because I could hear the sound that plays when a charger is connected or when pressing home+power to take a snapshot.

If I'd hold home+power for about 10 seconds, it would perform a "force reset" and power on and work normally, but once I shut down the cycle repeated itself. It was annoying, and I don't know what caused it, though I didn't transfer over the little flex cable with the magnetic sensors from the old display, so that might be related.

Anyway, I erased all content and settings, and this problem went away. I should mention, though, that I have not yet restored the backup I made before the LCD replacement.

Was this answer helpful?

Score 0
Add a comment

Add your answer

briiangullentops will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 3

All Time: 91