Fifth generation of iPhone. Repair of this device is straightforward, and requires screwdrivers, prying tools, and patience. GSM/CDMA / 16, 32, or 64 GB / Black or White.

2881 Questions View all

iPhone often restarts after battery replacement!

After battery replacement, iPhone while is power on, touch stop responds and in 1-2 minutes device restarts. Restarts keep happens and while is in standby. The problem is not appeared in specific time after boot up.

I tried 3 different new batteries and the problem still apears!

I tried also to reinstall the old battery and the problem disappeared!

I dont know what to do...

With the new battery I have better battery life but device keep restarting which is very annoying...

With the old battery I have no restarts but it needs charging every 3-4 hours!

Anybody can helps?

Device: iPhone 4S iOS 7.1.2. noJB

PS: I have to higlight that I changed the battery 2 more times in the past whithout any problem...what happens now???

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Check to make sure the new battery has the same APN number as the old battery. I remember when doing battery repairs for this model, we thought we received a bad batch of batteries (all were not working, or causing restarting issues), but it was an issue where some phones would act strange unless it had a specific APN number or the same APN number as the original.

Was this answer helpful?

Score 2

Comments:

I still believe it's a bad batch of batteries. I gave up doing iPhone 4S battery replacements. I've been getting too much refurbished, aftermarket or used batteries.

by

Could be, stopped doing phone repairs last year. I do remember we did get a batch in from China of a certain APN number (we requested this, after a couple of shipments were completely non-working) and 95% were working, other than the couple of obviously faulty ones.

I think they were original batteries, slightly used, but no difference in capacity from the original. We found it difficult to get more beyond this due to the age, and just gave up with the 4S'

by

The old one has APN: 616-0579 and the new that I tried to install were two 616-0579 and one 616-0581 (I have returned the other 2 so I cant find the number now)...

by

In that case, it sounds like it could be bad batteries, as @benjamen50 said. The device is quite old now, so it will be difficult to source good ones, but try looking for a genuine new/slightly used battery

by

Add a comment

Add your answer

Agnostos will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 43