Repair guides and support for desktop computers produced by Asus including towers and all-in-one display PCs.

36 Questions View all

Mouse Pointer Uninstalled And Drivers Won't Repair It

Hello, I am very desperate for help. I've asked the most professional computer guys in my city to help and they don't know how to fix it. I have disabled then uninstalled my mouse on Device management > Mice and other pointing devices > (I don't remember the name of the touchpad/mouse) > Drivers. I've been able to go back to this place by only using Tab, Arrows, Enter, Space And Backspace. My cursor is invisible and if i activate "Show where the cursor is when the Control key is pressed" on Mouse Properties it's stuck in the middle of my screen. I've multiple times tried to update my drivers back again and restarted my computer and nothing has happened. I'm thinking to factory mode my computer, but i'm afraid i will lose my windows key or won't be able to continue and get stuck at some point.

My computer is named Asus rog g752vt

- Chris

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

This might be a long shot, but have you tried updating your graphics/video card drivers? I'd probably try that next.

Also, if you haven't already, go into your pointer options try enabling pointer trails, and see if that makes any difference.

By the way, the model number you gave looks like it's for a laptop PC—have you tried both the built-in trackpad and an external/USB mouse?

Was this answer helpful?

Score 3

Comments:

Thank you for your comment, but none of that helped. I tried updating drivers on the graphic card and we went into every option for mouse; Pointer options did nothing for me. USB Mouse does not either work. I fixed the problem tho. I Just did a factory mode and that fixed my problem. If anyone would to have happen to have this problem and nothing else helps i suggest doing the reset your computer to factory mode. Anyway Thank you for your suggestion and helping me.

by

Add a comment

@booja It apears your computer is a laptop so are we dealing with a usb mouse or the trackpad . You may want to check in your bios for peripheral settings reset your bios to default to return the functionality . If you do need to reformat then you can use a key recovery tool like Majical jeally bean keyfinder . this will recover your product key so you can use it over again. Hope this helps

Was this answer helpful?

Score 3
Add a comment

Add your answer

Chris will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 32