Repair guides and support for the seventh generation of Ford F-Series trucks. Models include the F100 (discontinued in 1983), F150, F250, F350, and others.

7 Questions View all

Why is it stuttering on acceleration?

I just bought this 86 f250 with a 460 7.5 liter. The carburetor I had rebuilt, replaced plugs , wires, cap rotor and distributor. Repaired some vacuum leaks and replaced the smog pump that had froze up. If I just barely touch the gas it sputters and lurches forward. Not sure where to look next. I'm thinking of replacing the coil next and the control module due to my hunch that it is ignition related rather than vacuum related. Any ideas??

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Oh and yes I think that the egr is something that I need to look at. I cleaned the base when the carburetor was out but just bolted the egr back on without any inspection.

Was this answer helpful?

Score 0
Add a comment

Lance, Was truck acting up prior to you changing the parts? There are a lot of possible causes for this condition, recheck for vacuum leaks, use a can of starter fluid to spray around intake , carb. base, all vacuum hoses including brake booster if equipped. Check EGR for being plugged/faulty, could be an issue with carb's settings/ float levels/accelerator pump, choke, etc., check for pinched, collapsed fuel line, check fuel pump flow. If all seem OK then try your hunch, check/clean connections and grounds to coil and control module before replacing and try. Good luck.

I hope this helped you out, if so let me know by pressing the helpful button.

Was this answer helpful?

Score 0

Comments:

Each time I fix one thing it seems that another issue becomes apparent. I first did the carburetor and when I went to adjust the timing the distributor was frozen in the engine. It was ancient so I decided to replace it once I got it out. I did put in a new pcv valve. The engine compartment fuel lines I replaced when I did the filter. I'll double check those. I was wondering about the fuel pump too. On The forward gas tank the truck runs smoother than the rear. I've tried to run the rear tank empty and the refill it with fresh gas. Not sure if the pumps are in the tank or inline. Do you know where they are located? If each tank has its own pump, this could be the issue! I'm going to check around the brake booster for leaks. I'm also wondering about the evaporator canisters as a source of the leaks. The latest sputtering was after the replacement of the distributor and smog pump. The smog pump until this point was completely non functional.

by

I believe separate in tank fuel pumps, fresh gas is a good idea, if running better on front tank, rear tank pump could be weak, bad gas/filter,etc., also recheck check timing after fixing vacuum leaks timing can change, possible for vac. leak at canister do check, smog pump is new and working/ connections good, should be OK, egr can give the symptoms when stuck/carboned up. Good luck with the truck.

by

Add a comment

Add your answer

Lance Wallace will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 5

Past 30 Days: 10

All Time: 65