1.8GHz dual-core Intel Core i5 (Turbo Boost up to 2.8GHz) with 3MB shared L3 cache

239 Questions View all

Why is my battery still has "X" logo?

Hi guys, I bought the Macbook Air Mid 2012 (13") battery to replace the faulty battery. Unfortunately, it still says "X" on the battery. Is my MBA motherboard faulty? I did try "SMC" and "PRAM" reset but still not working.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Is the X black or red?

by

It's the black "X".

by

If you go Apple Logo>About This Mac>System Report>Power, what does the MBA tell you about the battery status?

by

It says no battery available.

Power source: Power adapter.

by

Battery information:

Charge information:

Charge remaining (mAh): 0

Fully Charged: No

Charging: No

Full Charge Capacity (mAh): 0

Health information:

Cycle Count: 0

Battery installed: No

Amperage (mA): 0

Voltage (mV): 0

by

Show 1 more comment

Add a comment

2 Answers

Chosen Solution

Check and clean the board for liquid damage. Likely the SDA or SCL resistors, which tell the SMC if the battery is present and the percentage (R5380 or R5381). Could be R7006, common to blow too.

If you have tried a new battery, will be logic board related. If you have no experience with micro soldering, or don't have the tools, would recommend sending this to someone.

Was this answer helpful?

Score 1
Add a comment

I would get my hands on another battery to use for testing the macbook - it could be a motherboard issue, or an issue with the charge control circuitry inside the battery pack. If you can't access another battery, I would take it somewhere that can diagnose your laptop for free so that you know what to replace.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Nuruddin Hadii will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 51