Northbridge sensor says 99c. CPU is doing nothing. Fan going nuts...

Hi

After replacing the old HHD with at SSD my fan runs at full speed. The fan kicks in just before the logn screen. If the laptop has been turned of for the night, then it takes a little longer before the fan starts in the morning. I dont think that it has something to do with the HHD replacement, because the terminal monitor says that the Northbridge temp is close to 100c. The CPU is doing nothing and running fine with at temp of 54c. So i think that its a sensor problem or something is really wrong with the Northbridge temp.

Screenshot of temp monitor:

Temp monitor

Ang suggestions how to fix this ?

best regards

Per V

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Have you tried the old hard drive, to see if the fan is still spinning? I don't think this would be the issue, but it's always worth a shot. Did you remove the board for any reason, or do you recall knocking anything? Also, it is worth giving the board a once over to check for liquid damage.

You are correct, sounds like a sensor issue if the fan is naturally ramping up as it thinks the CPU is hot. Run ASD for your particular MacBook and run this, it will give you some errors which should point you in the right direction. Let me know what codes it throws up.

Was this answer helpful?

Score 2

Comments:

Also, try usual SMC + NVRAM reset, and unplug everything but the keyboard, trackpad, hard drive, charging port and screen, to see if it still ramps up.

by

Hi Reece

Yes i tried with the old HHD with the same result. Tried SMC + NVRAM reset too. No change. Then i tried to boot with option-d but gets an error,. Seems that the laptop have a hard time with connecting to the internet :-(

Is it possible to do a Hardware test offline ?

/Per

by

You can download ASD for your particular model, they have different versions depending on the board number. This is more thorough than AHT and can be booted from an external drive.

by

Hi Reece.

Got the ASD working, and it confirms that something is wrong with a sensor:

Temperature (TN1D) -- MCP 0 Die : Sensor is reading below the low limit.

Also got this error:

Get pci-e link status failed

by

Ignore the PCI-E error for the moment. For the other error, check the resistors above the SMC (on back of logic board, it is the chip nearest the top with a line of components above it), since this is where a lot of the sensors are, and is close to the vent (easily affected by liquid). Compare the resistors to other ones on the board, to see if they look bad/different. If it is not this, give the board a check over for anything which looks odd.

If it is not this, I would say its the MCP itself, at which point you need to sell it on eBay for spares. The MCP cannot be bought new, and is not easy to replace, also can fail for no good reason in the 2010 models.

by

Show 2 more comments

Add a comment

Add your answer

Per V will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 3

Past 30 Days: 5

All Time: 72