WD my passport ultra 2TB is not showing up on explorer.

Hi, everyone. My WD Passport Ultra 2TB external hard drive is not showing up in explorer when I plug it into the USB port in a "normal way". I have to connect it through a "bizarre way" to make it show up in explorer. I realizes there were threads related to the same issue, but it's not what I am looking for.

Let me explain the "normal way":

I have another 1TB WD (same model as my 2TB WD) which behaves in a "normal way". Just plug and play. Nothing weird! Once I connect it, the LED blinks for a few times for successful connection. Done. I can find it in explorer

Let me explain the "bizarre way:

The 2TB WD behaves in a "bizarre way". If I connect it in the "normal way", it will not show up in explorer, Diskpart, or Disk management no matter how long I wait. In order to make the 2TB WD to show, I have to process the following steps every time I connect this 2TB external hard drive: First, plug in the USB cable halfway through any one of my desktop computer's USB ports. Then, wait for the drive to show up in explorer. Finally, I can push the USB completely into the USB port. The difference is that the successful connection of the 2TB WD happens when the USB cable is half way into the USB port.

Troubleshoots:

That particular 2TB WD behaves in the "bizarre way" on my Win 7 desktop and my Win 10 Surface Pro 3. However, it behaves in the "normal way" on my friend's Win 8.1 laptop, Ubuntu or Mac OS X.

Since my 1TB WD is working properly, I try to switch the USB cables between them. The 2TB WD still behaves in the "bizarre way". Thus, I can tell it's not a USB cable issue.

Also, I have tried to reformat the 2TB WD based on GPT or MBR partition tables. It still acts in the "bizarre way".

Does anyone know or understand what really happen to my 2TB WD? (For examples, driver issues, broken WD connector, ... etc..). Just in case my 2TB WD fails to show up completely in the future and that "Halfway-in-USB" connection trick does not help me to access that 2TB WD.

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Hi, I assume that you do not have access to another WD 2TB HDD to compare to prove whether the problem is with the drive or with your PC? Have you tried connecting it to a powered hub to see if your PC is not supplying enough power to it?

Have you also tried this to test your HDD?

https://support.wdc.com/downloads.aspx?l...

by

Thanks for responding. I have edited the description of my question. Feel free to view it again, please. And thanks for your advice from the link. I can actually access the 2TB WD, but only in a bizarre way. I just want to find out why it does that. I have tried to scan for bad sectors with software, but reports are normal. I also tried the official "WD Utilities" software to troubleshoot the problem. It finds nothing problematic.

I tried your method with a powered hub as well. It makes no difference. The hub I have with power adapter: https://www.amazon.com/Sabrent-Individua....

by

Hi, Found this link where the guy was having similar problem to you. There are two solutions offered which solved the same problem in different ways.

http://www.tomshardware.com/answers/id-2...

by

I'll give it a try. Thanks for the link. Just to clarify. That 2TB drive was OK before. It became to act strangely just about 2 weeks ago. I just worried that would be a sign of complete breakdowns coming.

by

Hi,

Suggest then if possible back up everything that you can when you do have access just in case. After that try using the 12V adapter power connector to see if it stabilizes as per connection/appearance in Explorer.

It still may be a compatibility issue between your PC and it due to perhaps component variations due to age (slightly less voltage supplied etc - all this is guessing of course as you say it is OK with other computers)

by

Add a comment

2 Answers

The most easiest way I discovered when encountered same kind of problem with my passport. in Control Panel go to Devices and Printers. That would be the only place you can see your passport visible. open its properties and then open drivers, simply uninstall it, come out unplug your passport drive. Restart your computer and insert/plugin your passport again into PC. It will automatically start installing drivers and here you can start using your passport drive comfortably.

Was this answer helpful?

Score 0
Add a comment

1. Try new cable

2. buy similar HDD WD and remove the new controller board and install on bad one.

Hope it fixes it, I am at the same place. All other nice recovery programs freeze when the HDD is connected!

Good luck

Was this answer helpful?

Score 0
Add a comment

Add your answer

xKase will be eternally grateful.
View Statistics:

Past 24 Hours: 83

Past 7 Days: 593

Past 30 Days: 2,321

All Time: 6,959