Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

798 Questions View all

The fan never stops

I upgraded my macbook pro 13" mid 2009:

replaced optical drive with 250GB SSD.

replaced 2x2GB RAM with 2x4GB.

replaced old battery..

Things work, except the fan never slows down and makes a lot of noise.

The fan start at full speed as soon as I click the power button, even before the screen lights up.

Please help.

Also the bluetooth and camera stopped working :(

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

it seems to be a issue on laptop board . try getting it repair in local somewhere

by

Do you have any suggestions regarding where?

by

Okay I ran AHT.

It shows error: 4SNS/1/40000000: TB3T-128.000.

Searching over internet it says it's an error in battery temperature sensor. That sounds plausible as I did replace the battery and can also explain the fan running high all the time (even before anything else turns on in the laptop).

Any ideas, how to fix it?

by

Add a comment
Black Friday
Broken doesn't stand a chance.

4 Answers

Chosen Solution

Usually this is a trackpad issue, but it can be caused by the battery or logic board. Have you tried reconnecting the old battery?

With the bluetooth and camera, check the silver plug in connector to the left of the board for burnt ferrite beads (little silver and black square things, will look slightly burnt and expanded if bad) and try to reconnect it (while battery disconnected). I have had to replace a lot of these in this area, they seem to burn out very easily. Try a NVRAM and SMC reset as well, since it is strange for both to stop working.

Was this answer helpful?

Score 2

Comments:

> Have you tried reconnecting the old battery?

Good, idea, I'll give that a try.

> With the bluetooth and camera, check the silver plug in connector to the left of the board for burnt ferrite beads (little silver and black square things, will look slightly burnt and expanded if bad) and try to reconnect it (while battery disconnected

Is that the silver plug with the small thin gold metals that plug in? (same as wifi?)

by

Shouldn't have gold bits, but it will be above the DVD drive connector and below the fan.

by

You aren't talking about https://d3nevzfk7ii3be.cloudfront.net/ig..., are you?

by

Yes, the top one with the yellow square around it. The image is for a 15" model, but it will look exactly the same

by

Okay I ruled out the old battery for the fan running high all the time.

by

Show 13 more comments

Add a comment

Try to take battery out and place it back in

Was this answer helpful?

Score 1

Comments:

This I have tried multiple times now.

by

Add a comment

You might need to replace your fan or make sure you did not damage the fan and as for your Bluetooth and camera check for loose connections .

Was this answer helpful?

Score 0

Comments:

Hmm ... there's no visible damage to the fan.

As for the connection, is the same connection as the wifi (the thin series of gold metals?) the wifi too didn't work at first, but I disconnected and connected it, now wifi works.

by

Try what you did with the wifi an see if that works

by

Add a comment

Try to hard reset the back book 1.Hold down the Power button on the keyboard until the MacBook shuts down completely, this may take 5 seconds or so.

2. Wait a few seconds then hit the Power button again to boot the Mac 3. Right when you see Apple logo immediately shut the Mac off aging .

Was this answer helpful?

Score 0
Add a comment

Add your answer

avidgr8 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 13

All Time: 170