Released in August 2015, Model number: P01M, Intel Atom Processor Z3530

14 Questions View all

Why won't the battery charge?

When I plug in my device the battery will not charge

Answered! View the answer I have this problem too

Is this a good question?

Score 6

Comments:

How can I tell if it is the port not working?

by

I'm refering to the usb Port on my tablet

by

Add a comment

3 Answers

Chosen Solution

Hi Jessica! Have you tried testing a different outlet to ensure that the charger itself is not working rather than the device?

For more help try visiting our Troubleshooting Page! ASUS ZenPad S 8.0 Troubleshooting

Was this answer helpful?

Score 1

Comments:

I tried that too but it didn't work

by

I have the same zenpad and found there is a trick to charging when the battery is completely drained. With the charging cable unplugged attempt to turn the zenpad on. The dead battery symbol will come on very briefly and when it does quickly plug in your charging cable. You will then see the green charging progress light.

by

Add a comment

I think it is a problem with the port. If someone can create a guide on that it'd help a lot. The usb-c port in this device is quite weak as easy to break.

Was this answer helpful?

Score 0
Add a comment

I has been charge my zenpad but still don't want charge why?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Jessica Voss will be eternally grateful.
View Statistics:

Past 24 Hours: 6

Past 7 Days: 71

Past 30 Days: 378

All Time: 11,055