Model A1502 / 2.4, 2.6, or 2.8 GHz dual-core Intel processor / Released October 2013

236 Questions View all

No SSD found in recovery mode after liquid spill and clean up

HI

Recently i cleaned my macbook with isopropyl alcohol because i spilled ice tea on it and when i tried to start my macbook again it showed me a flashing folder with a question mark.

After cleaning everything, I keep getting the flashing folder, so i tried the recovery mode, but when i tried to reinstall the OS on my mac he couldn't find my SSD.

I tried a lot to fix it but still nothing... anyone who can help me with this?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Try the SSD in another 2013+ MacBook Air/Retina to eliminate this being the cause. Check the SSD connector for burnt pins. Beyond this, you will need a board view, schematic and soldering skills.

In schematic, find the section about the SSD connector and check the board around the supervisor clkreq circuit for anything burnt. There are also a group of small resistors on the back of the board, on the side opposite the ports, which can easily be damaged by liquid, some responsible for SSD signals.

If it is the board, usually it is a nightmare, have a 2015 one myself I need to get to the bottom of. Make sure the SSD works first, then check out the board afterwards.

Was this answer helpful?

Score 0

Comments:

Jup that's what I did, and i ended up paying 50€ for a second handed ssd, which is no money compared to what apple services would ask for a repair, thanks for answering!

by

Add a comment

Add your answer

baptistetahon will be eternally grateful.
View Statistics:

Past 24 Hours: 4

Past 7 Days: 9

Past 30 Days: 37

All Time: 122