Intel DP45CB Motherboard won't POST, No Video on any outputs.

Have an issue on this platform that is driving me crazy as I just bought a new motherboard to restore an older Dell Inspiron that is still a great spec but I know I can make it better for cheap.

My LGA775 starts with no POST error beeps but there is a red led just before the PICe x16 slot lit constantly on a refurbished Intel DP45CB mobo, I can't find an answer to what that means online or in the manual.

Anyways, I'm unable to check anything in POST or get to the BIOS as I am getting no video from either of the DVI ports (DVI-I or DVI-D), straight or using a conversion adapter to VGA, DP, or HDMI. Also installed a video card, 2 actually (AMD & NVidia separately). I wanted to put the NVidia card in this build but I can't get any display output. Both cards tested and working so this makes no sense.

  • Converted a Dell i530 OEM to an Intel DP45CB
  • Intel Core 2 Quad x64 2.4GHz CPU
  • Intel Stock Cooler, Corsair H60 or the Dell stock *

* tried all 3, none made a difference

  • Crucial 8GB DDR2 800MHz DRAM
  • Dell Stock LiteOn 350w PSU or ThermalTake 750w PSU*

* tried both even though I knew the 750 wasn't the problem as I tested it and it's double the power of the Dell LiteOn original.

Anybody have any thoughts?

I am cataloging this build to post to YouTube but will also make a guide for here. Just need some feedback. Trying several places for help and happened to open iFixIt and saw all the new categories, figuring it can't hurt to put it out there...

Thanks in advance to whoever can help or has any input.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

Hi,

I cannot find the DP45CB mobo listed on the Intel site, only the DQ45CB or the DP45SG, therefore perhaps it is an OEM modified board. Your CPU should work with a DP45 series chipset however. Also the specs for your CPU show that there is no inbuilt graphics, so unless there is a graphics chip on the mobo which seems likely given the connectors you say are there, you will have to install a video card to get an output. Here is a link that I got that info from. Is it one of the two listed at the bottom of the table?

http://processormatch.intel.com/Processo...

Have you tried re-seating the CPU?

Have you tried removing/replacing the CMOS (RTC) battery to see if this will reset the BIOS back to the default values and then try starting your PC?

Is the 'power' light on the case coming on? (assuming that you have it in a case and the Power/HDD lights etc are connected). If there is no power light have you checked that the PSU is starting, I realize that you said that it is working in another situation? Here is a link that shows how to check a PSU. It should start from a 'power good' signal from the motherboard.

https://www.youtube.com/watch?v=5FWXgQSo...

Try starting the PC with just the video card installed (or not as you seem to have onboard graphics) and Power button connected, no RAM, HDD, ODD. etc. Disconnect the reset button connection, if any, from the mobo as well.

Silly question but have you got a speaker attached to the correct header pins of the motherboard or is it directly mounted? If directly mounted can you easily remove it and test it or replace it to prove whether there are POST beeps occurring?

Here is the product guide for an Intel DQ45CB mobo. (I realize that yours is a different model? but this may be close enough) which may be of some help to you.

It shows that the LED that you are talking about may be the +5V standby power indicator. Scroll to p.27

Here is the link.

https://downloadmirror.intel.com/16958/e...

Was this answer helpful?

Score 1
Add a comment

Add your answer

Rich OBrien will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 14

All Time: 213