MacBook Pro boot, chime, but no video, no backlight, no power led.

Hi:

I have a Macbook Pro A1278, which one, I tried to realize a internal cleaning and after reassembling, and turn it on, The equipment, boot, chime and the screen, flash for a second, but nothing else: the screen is black, no keyboard backlight, no power led indicator, fan, hard drive spin, light if Caps Lock press, even the Magsafe led is off.

I tried connecting a external monitor, and it works.

The battery since begining was dead, but, the laptop worked.

I already tried:

Reseting SMC, Reseting PRAM, Pressing Option key on start up. and nothing works :(

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

I think that there is an issue with your backlight circuitry. Was it the cleaning that caused this issue?

by

Add a comment

2 Answers

Chosen Solution

I would take out the board again and re-assemble, making sure all the connections are secure and that you didn't miss any. But first I'd disconnect the video cable and re-attach it, making sure the latch is in place, because sometimes even a slightly loose video cable will cause no video or no backlight.

When it powers up do you see a faint image (shine a flashlight through the Apple symbol from behind)? If you do, then you likely either have a bad screen panel (bad bulb) or a blown backlight fuse on the board. But the fact that the power LED is not working points to bigger issues, which is why removing the board again makes sense. While you have it apart, I would disconnect the DC-in from the board and let the two sit for an hour to discharge...sometimes allowing a "bad charge" to dissipate can cause normal behavior to be restored.

Was this answer helpful?

Score 3

Comments:

Hi, thanks for answer; the behavior is: when you starts up the computer the screen turns on whith a all-white image, but turns off immediately, and the same with the apple logo in the back, turns on just for a second and after turns off .

I have re-assemble several times but the result is the same.

No keyboard backlight, NO magsafe light, NO power led, and NO image on the screen. :(

by

Add a comment

When you cleaned it did you remove the Fan cooling assembly? Because if you did then you probably removed the assembly off of the CPU and the Video chip. And if you didn't replace the thermal paste before putting that unit back you could have fried the CPU and Video Chip as well.

Google videos about replacing thermal paste of your unit and you might see what you might have done incorrectly.

Was this answer helpful?

Score -1

Comments:

I don't think the problem is that, The Macbook turns on, boot, chime and everthing even when I connect a secundary monitor, I have video, and a screen of secundary desktop. If the cpu or video chip were fried, there wasn't booting and, neither video, on a secundary output.

I think is more a power problem, because the screen flashes for a second trying to turns on, even the apple logo in the back of monitor flashes too, and the keyboard light is off, the power led is off too, and even the light on the Magsafe connector, don't turns on.

by

From all the information sounds like the +- 5VDC down conversion of your computer isn't working. AKA: no lights. Probably no USB power either.

by

Add a comment

Add your answer

Cesar will be eternally grateful.
View Statistics:

Past 24 Hours: 8

Past 7 Days: 24

Past 30 Days: 130

All Time: 1,907