Sixth iteration of Apple iPhone, announced on September 12, 2012. Repair of this device is similar to the previous models, requiring screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Black or White.

3122 Questions View all

iPhone stuck on apple logo and doesn't charge

My problem started after I noticed that the phone was hot and the battery was discharged from 100% to 30% in a few hours. I tried to restart my phone but it stuck on apple logo.

I tried a hard reset with no luck. After a few attempts it showed the empty battery logo. I didn't tried again and after a couple hours I connected the charger but nothing happened. I pressed the power button and it wasn't even showing the empty battery logo. The battery was completely discharged which was odd since the phone was turned off. I connected a battery capacity meter between the phone and the charger to see if it was draining power but it stayed to 0 Ampere/0mAh. (I tried many different usb cables and chargers.)

I replaced the battery and connected the charger but the screen stayed black. I pressed the power button and it stuck again on the apple logo. Connected on my Mac and it didn't showed up neither on iTunes nor on USB connected devices.

Tried to enter DFU mode but after the apple logo disappears, I keep holding down the home button and it's not showing up on iTunes.

Is this a hardware issue? What else could I try before discharging the new battery.

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment
Deck the Halls
With tools and Fix Kits

2 Answers

Sounds like U2 IC damage. Make sure you use a genuine apple charger. This is a hardware problem, unfortunately. Send it to @jessabethany at iPad rehab. She can fix it.

(The u2 is is part of the charging circuit.)

Was this answer helpful?

Score 0

Comments:

Shouldn't it boot with the new battery if the problem is the U2 chip?

by

Add a comment

hi , u need to change the battery ( battery is dead )

Was this answer helpful?

Score -1

Comments:

He already did.

by

Please read my post. I replaced the battery and it stuck on apple logo again. Also it doesn't charge with the new battery and is not recognised by the computer.

by

Add a comment

Add your answer

Yan will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 4

All Time: 100