El Capitan install freezes

Just bought a Mac Mini A1283 (late 2009) with 8Gb ram and a new 500Gb HD. Lion 10.7.5 is on it and works like a champ. I want to upgrade to El Capitan which will run on this mini.

I made an El Capitan install USB stick (following instructions on the Apple support site) and booted up, but after about 40 minutes the progress bar stops at 99%. I let it sit for 48hrs with no change. Force restart and the progress bar restarts and makes progress to 99% then stops.

I've tried everything I could find in various forums - reset NVRAM, reset SMC, erased and reformatted the HD (passes first aid), replaced the battery, reset the date and time, tried a clean boot to a Yosemite USB (same result). I also tried to upgrade from Lion via the app store, both with Yosemite and El Capitan with the same result (stopped at 99%).

A clean boot from a Lion USB installer works every time, but the newer systems do not. I'm sure it is a simple authentication or certificate or verification issue at the end of the install, but this has me stumped. Anyone have some insight??

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

10.11 should install, however your machine is a 3,1 and Sierra will not:

– macOS Sierra won’t run on –

Mac Mini 1,1 – 3,1

You may have a bad block on your hard drive, Try reformatting using the "write zeros" option to map out any bad blocks and try it again.

Was this answer helpful?

Score 2

Comments:

Yes it is a Mac Mini 3,1 which should boot with El Capitan 10.11.

I formatted HD by writing zeros as suggested. Rechecked with first aid and it passed. Cleared NVRAM and booted from the El Capitan USB stick. Froze about 45 minutes later at 99% progress.

Cleared NVRAM again and booted with Lion USB Stick. Lion is fully functional.

Something is still preventing it from finishing the El Capitan install.

by

What's your RAM configuration? Check in "about this Mac" to make sure of what it's seeing. Also some of my older installs needed to re-downloaded (acted like they were out of date).

by

By the way, thank you for you excellent suggestions (I should have said that first).

"About this Mac" indicates 8Gb 1067 Mhz DDR3

Everyman.com has the following note in the Mac mini 3,1 specifications:

Standard RAM: 1 GB, 2 GB* Maximum RAM: 8 GB*

Details: *By default, 1 GB is installed as a single module (MB463LL/A) and 2 GB is installed as two 1 GB modules (MB464LL/A). Officially, this model is capable of supporting 4 GB of RAM, but as first reported by MacminiColo, this model unofficially can use 8 GB of RAM after applying EFI Firmware Update 1.2 (I'm not sure what this is or how to determine if I have it).

I'm also downloading El Capitan now to remake a new install USB stick (don't think that's the issue though). I did notice one post on another site that indicated there might be something date sensitive in the "Install OS X El Capitan.app" and suggested setting the date to 1/1/2016. I might try that next.

by

Before changing your date, check the date of the OS X installation. You don't want to try install on a date before it came out.

by

After reviewing the process in the Apple support site, I updated the firmware and did a clean install of El Capitan (I left the date alone). It installed and appears to be working as intended.

I would not have thought about memory without your suggestion. I believe the issue was the 8 Gb memory installed (by the seller just before I bought it) without the necessary firmware upgrade. Apparently OS X Lion did not care, but Yosemite and El Capitan did. The Everymac.com note about firmware requirements was the key.

Thank you so much for your insightful suggestions!!! A very frustrating problem has been solved.

by

Show 1 more comment

Add a comment

Add your answer

Russn will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 21

All Time: 212