sd device problem, possibly driver related

My sd device on my ASUS K55N laptop doesn't seem to be working.

I insert an sd 32gb chip into the slot but nothing happens. Actually I've tried a second chip and it to would not load.

I've read that uninstalling and reinstalling 'its' driver might solve my problem.

(1) where do i find the sd driver to uninstall and

(2)where do I find a driver to reinstall.

Thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hi,

If the card reader is not being detected then the drivers are most probably either not installed or corrupted or the reader itself is actually faulty. Has it worked before?

Try installing the drivers first. You will be advised whether there are drivers installed already or not.

If you have Win 10 installed here is a link to the latest Asus drivers for Win10

http://ivanrf.com/en/latest-asus-drivers...

(Do not install drivers for any other hardware if they are working alright leave it alone.)

Was this answer helpful?

Score 2
Add a comment

Add your answer

ben thomke will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 29