This Power Mac G4 has Mirrored Drive Doors.

91 Questions View all

No chime, black screen, fans all running?

I push the startup button on the computer, I hear a motor click or something, and then get no chime, no image, then after about 10 seconds all fans come on. The screen is an older 23" HD Cinema display. There is no paperclip hole in the optical drive to startup from OSX disk. I believe I lost the image when I reseated the Graphics card.

I've replaced:

(2) Hard Drives.

Battery

Logicboard

DP CPU

I've reseated or unplugged and plugged back in:

Computer speaker

RAM in all 4 slots

Graphics Card

Battery

I've reset the:

PRAM

Battery

Logic Board

Answer this question I have this problem too

Is this a good question?

Score 2
Add a comment
Black Friday
Broken doesn't stand a chance.

3 Answers

Most Helpful Answer

This is about the eighth question on this same machine. Try starting up holding the mouse button down to eject the disk drive.

Was this answer helpful?

Score 1

Comments:

Yes I know. It takes a while between ordering parts to try solution. I'm still considering upgrade, but want to get the computer working first. I have followed, pretty much everything suggested except starting up from OSX disk, which I can't do unless tray is open. Depressed mouse, pushed start up, tray did not open.

by

Took out optical drive, put OSX disk in tray, nothing. Hooked up firewire cable to Powerbook G4, not recognized as remote hard drive.

by

Good beginning +

by

I've never seen a full sized disk drive without an eject hole. What is the brand and model number?

by

I don't know the model, when I took optical drive cage out, there was an eject hole I could use, the way it was built with the hole pretty low on unit, the hole was covered by the frame of the (2) mirror doors. It is not the original optical drive, but has been working fine for several years.

by

Add a comment

boot with only one chip of ram and try using different ram.

Was this answer helpful?

Score 1

Comments:

I don't know the model, when I took optical drive cage out, there was an eject hole

I could use, the way it was built with the hole pretty low on unit, the hole was covered by the frame of the (2) mirror doors. It is not the original optical drive, but has been working fine for several years.

by

Took (3) RAM chips out, left (1) in, no change. Will locate a different RAM chip and see if that works.Will have to order, so will take a few days. Mr. Mayer also suggested this previously.

by

Add a comment

Lots of discussion with this issue but no one ever say, "i have a fix".

Has anyone ever solved this problem?

Was this answer helpful?

Score 0
Add a comment

Add your answer

R Michael Olexo will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 8

All Time: 2,217