The Apple iPhone 5s was announced on September 10, 2013. Repair of this device is similar to the previous models, and requires screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Silver, Gold, and Space Gray.

3006 Questions View all

Battery is not getting charged

Initially the fault was determined to be the U2 Tristar Charging IC chip (or whatever it's called on iPhone 5s). So I got it replaced but I still have the issue of it not charging the battery.

Tried another battery, might think of trying another charging port later. But what it does now it can still turn on, every thing works fine (excluding the fingerprint scanner since it got replaced) also the battery does work but does not get charged. Tried two batteries already, charge not going to the battery.

Is there some capacitor that I should check if it needs replacing on the charging circuit?

TL-DR: It's basically detecting plugged in on charging but not charging.

Update (09/12/2016)

Thanks for the advice @oldturkey03!

Changing the charger port allowed the battery to start getting power from the charging cable.

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

@benjamen50 I'd try another charging port before looking closer at the charging circuitry on the board.

by

It was the charging port... I feel so stupid now for not trying this before... Because I've seen this exact same symptom on a iPod touch 5th generation (after shorting the port on accident) and replacing the port fixed it too.

by

Ben, YOU'RE FIRED!

by

Is that a Donald trump reference...?

by

Add a comment

1 Answer

Chosen Solution

Marking as solved so I don't get emails of it not being solved.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Ben will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 78