Complete how-to and replacement guides for the original iPhone, iPhone 3G, iPhone 3GS, iPhone 4, iPhone 4s, iPhone 5, iPhone 5c, iPhone 5s, iPhone 6, iPhone 6 Plus, iPhone 6s, iPhone 6s Plus, iPhone 7, iPhone 7 Plus, iPhone 8, iPhone 8 Plus, and iPhone X.

24695 Questions View all

no audio after fixing broken screen.

So i broke the screen twice now =( that's not the issue at hand.

I replaced the lower dock,speaker,mic assembly and my iphone had audio for about 3hrs then it went away again.

It was very staticky and such, songs would play but sounded like they were skipping on a scratched disk.

I have tried everything that I know of please help. Will provide more info as requested.

Answered! View the answer I have this problem too

Is this a good question?

Score 2
Add a comment
Black Friday
Broken doesn't stand a chance.

3 Answers

Chosen Solution

From what I have come up with its the 'light' sensor flex cable that also handles the audio to the ear piece. I crushed my iphone in my hands the other day trying to replace the whole audio system so now I am back to my sony ericson. Replace the #3 flex cable, if you make a call 'to your own house phone' place your hand above your ear piece speaker and if your screen doesn't shut off like it should that's the cable that needs replaced. At least someone has a solution to the problem even if its at my expense :(.

Droid X here I come.

Was this answer helpful?

Score 1

Comments:

+Thanks for getting back with your solution

by

Add a comment

This fixed my problem too. I noticed that ringtones were working fine, but I had no sound otherwise and my silent switch had no effect. No vibrate either even when toggling in the settings screen. The cable had popped loose when I put the antenna cover back on after replacing a broken screen. Reconnected the connector and it worked perfectly.

Was this answer helpful?

Score 1

Comments:

This is exactly what happened to me. Carefully reconnected the connector (and putting that dreadfull antenna back into place) and screwed on the protector to keep it in place and it worked!

by

Add a comment

I had the problem after a screen replacement. I notice the the vibrator that sits under the logistic board wasn't flat and making a good connection. I went and straightened that up and made sure the copper prongs on the loud speaker was clean and making a good connection. I hope that this helps someone. I was at my wits end.

Was this answer helpful?

Score 0
Add a comment

Add your answer

addictive blahblahblah will be eternally grateful.
View Statistics:

Past 24 Hours: 6

Past 7 Days: 76

Past 30 Days: 322

All Time: 14,650