Skip to main content

The Apple iPhone 5s was announced on September 10, 2013. Repair of this device is similar to the previous models, and requires screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Silver, Gold, and Space Gray.

4095 Questions View all

Power button not working after battery replacement

I replaced the battery on an iphone 5s using the ifixit kit.

Everything is working fine except the power button. It clicks but the phone won't turn on/off.

Any ideas?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

3 Answers

Chosen Solution

First of all, double check if the volume button + power button ribbon that goes under the battery at the upper part of the battery is plugged into the connector on the logic board.

The power button + volume cable ribbon is most likely damaged from when the battery was being pryed up near the top left part. The only way to fix that is to replace the whole volume + power button ribbon cable.

You can get the part from here:

iPhone 5s Audio Control and Power Button Cable

Guide to replace the part:

iPhone 5s Upper Component Cable Replacement

iPhone 5s Audio Control and Power Button Cable Image

Product

iPhone 5s Audio Control and Power Button Cable

$24.99

Was this answer helpful?

Score 4

Comments:

If the issue is the "volume button + power button ribbon", wouldn't the volume buttons also not work? In this case, the volume buttons continue to work.

by

No not in all cases as the wiring in the cable is split up for those functions.

It's actually common for power button to go bad itself on iPhone 5 or 5s.

by

Add a comment

Solution was to simply set the hour and date, by connecting it to iTunes.Same problem here, but solved

Was this answer helpful?

Score 1

Comments:

What do you mean

by

Add a comment

Better to start to power on using the line No7 / at j2 connecter (short with ground using tweezer), if power on , then change the power switch flex cable , if not working then check line 9 volt , it should be 1.8 v and if not check the line from AMBER PMU to the connector , following pics of mine will help:

Block Image

Block Image

Was this answer helpful?

Score 0
Add a comment

Add your answer

Ilia Lobsanov will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 20

Past 30 Days: 53

All Time: 5,360