2.26 or 2.4 GHz / White plastic unibody enclosure

587 Questions View all

No light on MagSafe LED & can't turn on my MacBook

Hi all,

My macbook 2009 suddenly will not turn on one day.

  • No response at all when pressing power button.
  • Plugged in MagSafe power adapter in doesn't show any light on LED (green or amber)

I went to Apple Store they suggested it's the issue with MagSafe/DC-In board since they tried with a new power adapter and still there is no light on the MagSafe LED.

So I bought a new MagSafe/DC-In board, changed it out, but still dead. Tried SMC reset that didn't help.

What should i look into next? Would it be just dead battery or something else?

Any advise would be great!

Thanks.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Tough one to diagnose over the internet. There are no clues.

Try this. disconnect the battery (check it for swelling while your at it). Dis connect the mag-safe adapter. Press and hold the power button for 15 seconds. Reconnect, try starting and tell us if you get anything.

Was this answer helpful?

Score 2

Comments:

I do not have the Y1 screwdriver. I tried to do your suggestion but with only disconnecting the battery cable. Nothing happen, stays dead. I will try to get a Y1 and see if battery is swelling.

by

Add a comment

Add your answer

Karaz will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 81