The Sony Xperia Z3 is an android smartphone released in 2014 known for it’s long battery life and durability.

104 Questions View all

Possible to fix broken radiocable mount?

Block Image

Block Image

Hi

When trying to fix my phone I sadly broke my radiocable mount. (only the upper) This causes bad signal on my phone. Is there a solution to this problem? Could I simply just glue it on?

Help needed!

edit: The problem is that the blue cable should have a munt within the red circle as shown on the picture. On my phone the little ring around the little "nipple" in the middel is gone /or stuck on the cable. This causes bad or no conection whtch causes bad signal.

Apears to be better when i hold the cable in the right place with my fingers.

Update (08/21/2016)

I was not able to take a good picture. However i tried to draw (whit poor skills) the problem. It is the circkle that is missing. The squere is black and beneth the circkle and middel dot, i dont know if it has any function at all. It seems to work as intenden when held in place. Witch I think suggest that it is just the munt that is broken not the conection. The thing in the middle that goes in to the hole in the cable is still there.

Block Image

Block Image

Hopefully the drawings will be suficient:) Thanks a lot for the help so far!!! Verry gratefull

Block Image

Block Image

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

@marste post an image of what you broke and where it's broken with your question. that way we can see what you see. Use this guide for that Adding images to an existing question

by

@oldturkey03 now i have a picture. Thanks for the help so far:)

by

Add a comment

1 Answer

Most Helpful Answer

Hi,

I've had the exact same problem before, I took the part that broke off and soldered it back on, don`t know how good you are with soldering, just don`t glue it on, it has to be soldered for it to work properly, also can you send a picture of the damage? want to see if the solder joint broke or if the pad is torn

-Jonas

Was this answer helpful?

Score 1

Comments:

Hi i have now added more info. Hope it is suficent

by

my solution would be to replace the connector, you might not have the right resources but its a possible fix, i took the connector off a old iPhone 4 motherboard and it worked, see if you can find someone in your area that has the right tools/skills to replace this

by

Add a comment

Add your answer

Martin Steimler will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 4

All Time: 93