Skip to main content

1.5 Core Solo, 1.66 or 1.83 Core Duo, or 1.83 or 2 GHz Core 2 Duo processor. This covers the first Intel-based Mac Mini models from Early 2006 to Mid 2007.

141 Questions View all

Mac Mini doesn't power up after cpu and Ram upgrade

I've upgraded the cpu of my mac mini and the Ram. The very first boot went fine, the system started (Os X Tiger) and cpu and ram have been detected correctly, but after less than a minute it suddenly power down. I've neve been able to power it up again. No fan, no light, no chime nor video. I can't smell anithing strange, there is no sound at all. I've tried to put back the original cpu and Ram with no luck.

Unfortunately I have no other power supply to test, and I fear the logic board is probably gone, even if I can't really understand how.

I've even tried SMC reset.

Apple store is not an option, this computer is ten years old.

Any other suggestion?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Please give us the exact specs of the CPU you put in

Also see if pulling the RAM allows the system to start up.


The processor is a core duo 2 t7200 2ghz

I think I've used enough Artix m4 thermal paste. Anyway I've tried even with the old processor but nothing has changed.


To be sure here you had a Macmini1,1 series system with either a 1.5 GHz Core Solo (T1200) or a 1.66 or 1.83 GHz Core Duo (T2300) and you wanted to put this CPU in: Core 2 Duo 2.0 GHz (T7200) in your system.


Did you put enough thermal paste?


Yes I've used enough thermal paste.


Add a comment

3 Answers

Chosen Solution

The Macmini1,1 system won't support the newer Core 2 Duo 2 GHz T7200 CPU. You'll need a Macmini2,1 series system to use the Core 2 Duo chip.

Was this answer helpful?

Score 2


actually it's quite a common practice to "upgrade" mac mini 1.1 to 2.1 by replacing CPU and even change the firmware. There's even a good guide right here on ifixit (it's the one I've followed): Mac mini Model A1176 CPU Replacement


Sorry guy the guide is a bit misleading ;-{

You really can't alter the older Core Solo or Core Duo to a Core 2 Duo Mini as many have the older support chips which can't support it. But! You can upgrade a Core Solo to a straight Core Duo.

Yes, I know about some have upgraded the systems firmware and gotten it to work. But you only have a 50% chance of having the newer rev logic board which has the updated logic which will allow it. Clearly from what you have posted you've got the older logic board.


Oh my! This makes sense!! Do you think I've been able to damage the logic board? At least it started even if for few seconds and correctly detected the cpu.


@danj Are you really sure about this? I was just about to do this upgrade to a t7200, on a 1.66 Core Duo.

I haven't done one in several years but I upgraded several iMacs, but my thinking isn't as good as usual today. Will have to look up my old posts on doing it. I have several iMacs with bad logic boards and was just checking before pulling a t7200 or a t7600.


The Macmini1,1 can support a Solo (T1200), or Duo (T2300 & T2400) it can't support a Core 2 Duo (T5600 & T7200) without first refreshing the firmware with the newer Core2Duo firmware first. If you do it the other way the system is toast. The last get'ya, here is only the newer rev boards work! The P series chips are a no go no matter what, as the power supply can't support it.


Show 5 more comments

Add a comment

Hi I've taken apart my Mac mini 1,1 and clean it all out and reapplied the thermal paste and now it won't power on at all.

Any help would be much appreciated.

Was this answer helpful?

Score 0
Add a comment

Block Image

My Mac mini 1,1 wouldn’t power after I upgraded to a T7200 as well. I put original cpu back in and still no power. I decided to look at board to make sure I didn’t damage it then I Noticed something labeled SW5900. It’s a switch I held it down for several seconds reconnected all parts except lid plugged in and it powered up.

Try pressing the SW5900 switch while unit is unplugged switch is located near cpu.

Gonna upgrade firmware to 2,1 then try upgrading again

hope this helps someone

Mike L

Was this answer helpful?

Score 0
Add a comment

Add your answer

Massimo Di Leo will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 1,319