The Apple iPhone 5c was announced on September 10, 2013. Repair of this device is similar to the previous models, and requires screwdrivers and prying tools. Available as GSM or CDMA / 8, 16, 32 GB / White, Pink, Yellow, Blue, and Green.

1369 Questions View all

Can't get past the Apple logo at startup...

So I replaced the Lightning Connector and Display panel on my son's iPhone 5c. Now the iPhone won't boot up?

It gets stuck right after the Apple logo appears... then there's a series of lines of type that appears (like the kind you would see on a PC when you're on the "boot-up screen")...

The lines are so small I can't really read what says but it goes through several checks and gets stuck at the same place/line each time.

Has anyone seen this before?

I'm wondering if I damaged the Logic board or if it's a battery issue. The phone does get really hot... and I had trouble removing the battery and those combative adhesive strips (even with 4 or 5 rounds of heat bags to soften the adhesive)!!

Update (07/28/2016)

So... I found out that one can do a "Recovery Mode" process using iTunes. The wanted to fix itself but it failed to first Update (saving your content) and secondly... it wouldn't even do a full Restore (erasing everything and reinstalling a fresh OS)... it kept resulting in error codes 4013 or 4005 each time I tried Recover Mode.

I'm so bummed.

It's my son's phone and I'm a truck driver and leave tomorrow for 2 weeks. My wife works too (6 days a week and does several different shifts) so my son needed the phone for communication with us and emergencies. I don't have the money to replace or even fix this phone! I'm at a loss!!

A Logic board will run me $150 and a new battery costs $30. I just spent $100+ and it still doesn't work...

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Can you post a hi-resolution picture of the error?

by

try removing the camera flex and power flex, prompt to boot with cable

by

Add a comment

1 Answer

Chosen Solution

Hi, if it is coming up with text on the screen, this tends to relate to the front camera flex, try unplugging that and see if it boots, if it does, the front camera flex needs replacing. :-)

Was this answer helpful?

Score 4

Comments:

beat me to it ;)

by

Thanks guys... I'll have to try it when I get back from my road trip...

by

I do try @ethanchow00 ;) haha

No worries Andy! Let me know how it goes!

by

Add a comment

Add your answer

Andy Kotz will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 5

All Time: 110