PNY CS 1311 SSD doesn't work attached to internal HDD cable. Why?

I recently got a new SSD (PNY CS 1311 - 480 GB.) The drive itself seems good – it works fine when attached by USB to my MacBook Pro (MBP) and by USB and SATA to my PowerEdge SC440 and my girlfriend's Latitude E6540 – but I can't get my MBP to work with it when it's attached to the internal hard drive (HDD) cable.

Here are some symptoms when the SSD is attached to the HDD cable:

  • If I try to install OS X 10.11 to the SSD (GUID partitioned with 1 blank HSFS+ partition) using a USB installer, the partition on the drive is available as an installation target, but the installation fails with the error message: "An error occurred while preparing the installation. Try running this application again."
  • If I try to erase or partition the SSD (un-partitioned) using the USB installer's Disk Utility, I can see the disk but get errors like "Couldn't read to end of disk."
  • If I try to erase or partition the SSD (GUID partitioned with 1 blank HSFS+ partition) using Disk Utility in the USB installer, I get the error message: "Couldn't unmount disk."
  • If OS X is installed to the SSD, which I can do by attaching it through USB, and I try to boot, I get the question-mark folder.

None of these are a problem if the drive is attached by USB; when attached by USB, the drive can be erased, partitioned, installed/duped to, and booted from to run OS X without issue.

So far, I've tried:

  • Reset MBP NVRAM/PRAM & SMC.
  • Verified that the MBP EFI & SMC firmware are up to date.
  • Replaced hard drive cable with new one (from eBay.)
  • Verified that SSD firmware is up to date (thanks to Dan for this suggestion.)

Anyone know why this doesn't work or what I can do to fix it?

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Your PHY SSD specs: PNY CS-480 GB 1311 SSD

by

Add a comment

2 Answers

Chosen Solution

Per PNY tech support: this MBP doesn't support SATA II/III-only drives, which this drive is, so I wound up returning it.

Was this answer helpful?

Score 1

Comments:

I'm very surprised! I've got Samsung SSD's in a few so theres something unique with the PNY drive. Sorry it didn't workout.

by

It's all good - I very much appreciate your help. FYI, the PNY dude claims a drive has to be SATA (I) compatible to work in this particular MBP and the PNY CS 1311 is only SATA II & III.

by

Add a comment
Most Helpful Answer

Your system's SATA port is SATA II (3.0 Gb/s) and this SSD is a dual speed drive SATA III (6.0 Gb/s) and drops down to SATA II (3.0 Gb/s). So from the specs you should be working!

So what could it be??? As you've already addressed making sure the systems firmware is up to date and you had replaced the drive cable (hopefully with a new not used cable) You've hit the top two issues.

So the only thing I can see here is the SSD's firmware. Now the rub...

You'll need to use a Windows based system to run the PHY tool to check it as well as update it if needed. Here's a link to the PNY firmware Update: Firmware Update.

Of course its possible you have a bad SSD here as well... Have you tried exchanging it yet?

Was this answer helpful?

Score 2

Comments:

PNY Drive Utility on my girlfriend's Windows machine declares the drive not eligible for firmware upgrade and therefore (presumably) it's running the latest firmware.

by

I'm dubious that the SSD itself is "bad" since it works in every other machine I put it in, including other SATA II machines like my PowerEdge server. It may well be incompatible with this MacBook due to the MacBook not doing what it says, though! I'm not sure if it's right to return it on that basis, but perhaps that's what I'll be driven to; however, it'd be nice to figure out why it doesn't work before I do that, so I can get one that does work and edify the general public.

by

The replacement HDD cable was listed as new from a reliable supplier on eBay. I wouldn't bet my life that it was fresh from the HDD cable factory necessarily, but I'm disinclined to continue barking up that tree without some way to test the cable (other than installing another new one of maybe better provenance and hoping it works this time.)

by

Did the cable have peal off strips on the sticky surfaces? If not it was used. I've also gotten new damaged ones on eBay.

by

The drive doesn't care what system its in as long as the SATA standard is correct.

I'm with Mayer here if the PNY drive utility tells you its up to date and you have proved it works in other systems then the SSD drive is not the issue it has to be the drive cable!

by

Show 8 more comments

Add a comment

Add your answer

Mike Sorice will be eternally grateful.
View Statistics:

Past 24 Hours: 5

Past 7 Days: 22

Past 30 Days: 96

All Time: 1,295