Fifth generation of iPhone. Repair of this device is straightforward, and requires screwdrivers, prying tools, and patience. GSM/CDMA / 16, 32, or 64 GB / Black or White.

2897 Questions View all

iPhone 4s won't turn on

On Thursday I replaced the screen on my device and the repair went off without a hitch. I was on iOS7 and on Friday I backed up my phone and upgraded to iOS9. The upgrade was successful, and I downloaded the Pokemon Go app.

For the most part, everything was working perfectly fine. I could play the app no problem, and the phone was working just as well as it was before I started doing all my repairs on it (which included an audio jack cable and vibrator about 4 weeks ago).

Today I was playing Pokemon Go at a park and I couldn't connect to the server. At about 17% battery power left, I closed all my apps and turned off the phone in an attempt to reboot the system. This is the first time I turned off my phone since the upgrade to iOS9. Now the phone won't turn back on. I've tried charging it (the phone gets warm so I believe it is charging), I've held the home button and the power button for upwards of a minute, and I replaced the battery with a new one.

Does anyone have any idea what might be going on? The repairs I did to the phone were successful; it was working perfectly fine for four days from Thursday to Monday after the screen replacement. Ever since I shut my phone down I haven't been able to turn it back on. I have it charging right now with the new battery pack and the battery pack is warm, so there is power going to the device.

The only thing I can think is when I replaced the screen the home button was a little loose. It wasn't quite as flush with the rest of the phone display and it can rotate easily. Would this be a problem? Have I somehow put the home button in a spot where it's constantly pressing against the sensor?

Any suggestions or help would be greatly appreciated!

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Even if the home button was faulty it should still turn on and holding the home button and power for ten seconds triggers a hard shut off so no need to hold it longer.

Maybe the screen ribbon cables are loose as in they unplugged themselves check if they are plugged in otherwise maybe the screen is at fault. Try replugging battery first though.

by

Hey Ben, thanks for your answer.

I've tried holding the power and home button for over a minute with no response.

The screen ribbon cables are not loose. I just went into the phone to check and detached and reattached them. I also reinstalled the old battery because I've had problems with faulty batteries in the past, so it's not a battery issue.

I've gone through iTunes a few times to try a restore. My first attempt tried to simply update the phone, but iTunes said it could not update and I had to Restore. I've restored the phone 4 times now but the screen is still unresponsive.

What's strange is that the restore process seems to be successful. It goes through the motions and ends with no issue or command prompt, but the screen is still black and when I plug the phone back in, iTunes says there's a problem with the device and needs to restore.

If I had to guess, the update killed the phone. I didn't have a problem until I shut it down today, and now it seems impossible to get it back online.

by

Add a comment
Black Friday
Broken doesn't stand a chance.

3 Answers

Call apple care on a different phone or look online a store has apple care I do not know I am a kid what do I know good byeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee

Was this answer helpful?

Score 0
Add a comment

Hi James I am EllaBella I have this problem too so but 1 person gave my a answer so I will tell you charge the 4s for a bout an hour or 2 then iTunes will maybe show up when it does click it and iTunes shall load and it will be fix. I have a other answer I will tell you in a bit. from EllaBella a little kid genus

Was this answer helpful?

Score -1

Comments:

Thanks EllaBella. I've been charging the device for hours now but there hasn't been a change. Also, iTunes recognizes the device but when it attempts to restore, the screen is still dead and iTunes continues to tell me there's a problem with the device.

by

sorry james I just under 1 1 so yeah not genus here

by

Add a comment

Hi James me gain EllaBella with an other answer so If you do not have iTunes like me on your 4s go on to your computer or laptop and click iTunes then put your phone charger to your computer and to your phone and something happen after that cause I ain't a genus I am a kid so ya. byeeeeeeeeeeeeeeeeeee!!!

Was this answer helpful?

Score -1
Add a comment

Add your answer

James Rysinski will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 1

All Time: 135