Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

854 Questions View all

SanDisk X400 1TB SSD won't boot internally - is it too big?!

My mid-2009 MacBook Pro was getting slow with its 750 GB hard disk, so I decided to upgrade to a San Disk X400 1TB SSD. I formatted the disk using a Sata to USB cable, clean installed Mavericks and used migration assistant to transfer my files. I can boot the laptop from the drive just fine using the USB cable. However, when I connect the drive internally, it won't boot. If I then connect the old 750 GB drive to the USB cable and boot it from the old drive, the new drive shows up on the desktop, but I can't open it or otherwise do anything with it. SanDisk thinks my computer may not accept a drive that size (that 1TB is too big!) but I don't think that's right. Can anyone help me out with this?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Free shipping on orders over $20
Use code BLUEANDBLACK at checkout
Free shipping on orders over $20

2 Answers

Chosen Solution

You have a known issue! Your HD drive cable needs to be replaced here.

The issue here is the drive cable you currently have is SATA II (3.0 Gb/s) which is fine for your old SATA II HD. But now you've put in a SATA III (6.0 Gb/s) SSD which is having problems with the old cable.

Here's the part you need: MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable - Apple P/N 923-0104. Don't use the older version of the cable! And here is the IFIXIT guide you'll need to follow: MacBook Pro 13" Unibody Mid 2009 Hard Drive Cable Replacement.

You also may want to check your systems firmware: About EFI and SMC firmware updates for Intel-based Mac computers. Make sure you're at the level listed or newer.

MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable Image


MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable


Was this answer helpful?

Score 3


Yeah! Thanks so much!


I solved my problem by buying this cable and installing it, HOWEVER the bracket for screwing the thing down was NOT the right size for my machine. The cable worked, but I had to break the plastic bracket in half and only screw down one side (the other side was bumping up agains the plug. If you have a problem like mine, make sure the vendor guarantees the proper fit for your machine.


@moodytrans - John, Sorry I should have noted the needed alteration to the cable. The older cable does not hold up as well.


Add a comment

No need any SATA to USB cable.

Just use a OS X installation USB drive to boot up the computer and use Disk Utility to make partition and format the drive. Then you are done.

X400 SSD is compatible with SATA 3.0 Gbps and 1.5 Gbps

Was this answer helpful?

Score 0


Wingman - The cable in question is the internal drive cable. Apple's original cable was not spec'ed for SATA III (6.0 Gb/s) drives. So when you put in a SATA III capable drive you'll encounter problems like this.

For reference: SanDisk X400 spec sheet

And Yes! You also need the OS to prep the drive. The SATA to USB cable is one like this: Startech 2.5" SATA to USB adapter which allows you to mount both drives up to the system so you can prep the drive & migrate your user accounts, apps & data over to the new drive. Which John had tried but if failed because the internal drive cable was bad.


Add a comment

Add your answer

John Moody will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 8

All Time: 459