Released September 25, 2015. Model A1688/A1633. Repair of this device is similar to previous generations, requiring screwdrivers and prying tools. Available as GSM or CDMA / 16, 64, or 128 GB / Silver, Gold, Space Gray, or Rose Gold options.

873 Questions View all

No Service After Housing Upgrade

A few days ago I transferred my iPhone parts to a black + gold rear housing, and everything was perfectly fine until today when I took it to work. The majority of the time it says "No Service", and hangs when there is service. However, when I take it upstairs, it works perfectly fine. Everything was also working properly when I was at home. Any idea what I could've done wrong? Prior to this T Mobile was connecting just fine here. There were one or two screws I put in the wrong place (like a 1.5mm screw in a 2.1mm pot), as well as some screws left over. Maybe I scratched a resister off?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

The screw posts on the rear case must not be colored, otherwise it won't be conductive and you will lose the antenna structure, especially LB/MB cellular diversity, 2.4G, GPS and NFC.

If the screw posts are colored, clear the paint with a dental drill. Install all the screws and contact washers, they serve as antenna connectors.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Anun Azganun will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 4

All Time: 107