New carby, New Fuel Filter, New Air Filter, But stalls at idle?

New carby, New Fuel Filter, New Air Filter, But stalls at idle?

The carby came preset for the bike with green paint pen lines on the adjuster screws.

So now im at a loss as to why it stalls, hot and at idle.

Doesn't stall cold, and choke open or closed makes no difference.

The accelerator cable is stuffed though so the cable is realy loose could this cause this?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

What make and model is your Quad?

by

Make: Zhejiang Easy Vehicle Co Model:YK125 Engine model:IP54FM But it is also stamped with GMX YK125

by

Thank you. @jimfixer & @oldturkey03 I have fixed it turns out the carby I purchased was for a smaller engine, and was preset incorrectly, so the poor thing was actually starved for fuel, after a few Youtube videos and some time I have it running Perfectly.

I thank you both for your time anyway Cheers.

by

Add a comment

1 Answer

Chosen Solution

A few things you may want to consider . How fresh is the fuel . do you have a clean air filter or is it plugged . if the throttle cable is stuffed is the choke cable also. Make sure its closing completely if the bike is running with the choke partially open it will run fine cold but as it warms up it will suffer. check to see its closing completely .Hope this brings Joy

Was this answer helpful?

Score 2

Comments:

Thank you. @jimfixer & @oldturkey03 I have fixed it turns out the carby I purchased was for a smaller engine, and was preset incorrectly, so the poor thing was actually starved for fuel, after a few Youtube videos and some time I have it running Perfectly.

I thank you both for your time anyway Cheers.

by

Add a comment

Add your answer

Konastar will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 50