This model was released years ago and continues to be produced. The disassembling is straightforward as long as you follow the instructions.

4 Questions View all

How do I disassemble my Wahl Stainless Steel Lithium Ion + Groomer?

I researched and bought a Wahl Stainless Steel Lithium Ion + Groomer to help me stay within regulations as I was deploying to the Middle East.

During my research I found a number of complaints about the on/off switch failing and the ability of the groomer to accept a charge.

Initially the unit I bought worked well and had no problem with either the switch or charging. However, after owning it for about a year with light use, both of these problems emerged and now I can only turn it off by inserting the plug in the recharging jack.

In order to repair/troubleshoot the problems I need to know how to disassemble the razor/groomer.

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Chosen Solution

Hopefully this IFIXIT guide will help you: Disassembling of Wahl Lithium Ion Trimmer

Was this answer helpful?

Score 3

Comments:

This link won't work because it's for the regular lithium ion, not the stainless steel. I have this problem too because I can't find a safe way to remove the silver led display off to get to the screws inside. Faulty production engineering?

by

For the stainless trimmer you'll need to pop the rubber power button off to access the screw under it. Use a thin knife point to get under the rubber and pry away from the shaver. After that, you can get to the two case screws under the bezel.

This is all a moot point due the the fact that I have ohmed all the hard wires on mine, only to find that there is something within the boards that is not allowing it to accept the charge or that will initially start charging, but then stop shortly after. It may be that the battery is sending out a false full charge signal...TBD

by

Add a comment

Solved my problem! ! I used the shaver until it died, plugged it in and left. When I came back hours later, my trimmer wouldn't turn on, and if I plugged it in the blue light would flash and do not more. While attempting to disassemble it, I discovered the screw under the power button was loose and partially backed out. If I pressed the power switch without the button in place, the razor tured on. By tightening the slightly, everything works normally

Was this answer helpful?

Score 1
Add a comment

Add your answer

Jim Mikkelsen will be eternally grateful.
View Statistics:

Past 24 Hours: 5

Past 7 Days: 35

Past 30 Days: 226

All Time: 2,522